404 redirects to home page when url has ? mark

Community Forums Forums General Discussion 404 redirects to home page when url has ? mark

This topic is: not resolved

This topic contains 7 replies, has 2 voices, and was last updated by  thisissripriya 1 year, 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #53383

    thisissripriya
    Participant
    Post count: 3

    Hi,
    We have a wordpress website which uses the custom permalinks plugin. When I access a non-existent page on the site such as http://www.xyz.com/abcd, I get the 404 page. However, if I have a “?” (question mark) in the url as in http://www.xyz.com/?abcd, it gets redirected to the home page instead of showing me the 404 page. Could anyone please tell me if there is some way to prevent the redirection to home page, when the url contains “?” and the page is not found on the server?
    Thank you.

    #53385

    AC
    Blocked
    Post count: 7712

    What is the actual URL of your website so we can see your code please.

    #53386

    thisissripriya
    Participant
    Post count: 3

    Actual url is http://www.nriol.net

    #53387

    AC
    Blocked
    Post count: 7712

    You are using SEO Ultimate – look inside there for 404 redirects. If they have settings for that, then create a redirect for it. I know a log of people are using the Yoast SEO plugin and there are redirect settings in there.

    #53390

    thisissripriya
    Participant
    Post count: 3

    Thank you. I tried disabling the SEO Ultimate plugin to see if that was causing the issue. The non-existent url with “?’ in it still redirected to the home page even when the SEO Ultimate plugin was disabled.

    #53392

    AC
    Blocked
    Post count: 7712

    You misread what I wrote. I didn’t say to disable the plugin, I said to check the plugin to see if there is a 404 Redirect function in there that you can set. Yoast has redirects built into it.

    #53393

    AC
    Blocked
    Post count: 7712

    I did a search for you on Google – read some of these – http://goo.gl/SCt6Fy

    #53516

    thisissripriya
    Participant
    Post count: 3

    Thank you. I checked the available settings / functions in SEO Ultimate and there was no 404 redirection available.
    I’m just checking the other plugins in the site to see if any of them have some function which redirects to home page.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.