Access Key Form Not Working

Community Forums Forums General Discussion Access Key Form Not Working

This topic is: not resolved

This topic contains 1 reply, has 2 voices, and was last updated by  Lauren @ OnceCoupled 1 year, 5 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #101814


    Hey Studio Press.

    I’m trying to purchase the Genesis framework. However when I go through the processes it asks me to submit my name and email address in order to receive an access key to go through to the next stage. This form does not work for me, as when I click submit, nothing happens. I have tried with different browsers, with my laptop and with my phone, and tried clearing my cache. Still nothing. I was wondering if there is anyway to bypass this or maybe have someone email me an access code? I am trying to redesign my website and have very limited time to do this as I am travelling and my next destination will have poor internet.

    Thanks very much.


    You’ll want to contact technical support about this. Best of luck!

    I do custom WordPress work!
    Contact me directly:

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.