Add a logo header with a link

Community Forums Forums General Discussion Add a logo header with a link

This topic is: not resolved

This topic contains 9 replies, has 7 voices, and was last updated by  John 1 year ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #22357

    Glade
    Participant
    Post count: 5

    It seems all of the newer themes suffer from the same difficulty…adding a logo to the header. Instead of using the WordPress title and description, I’ve been trying to add an image using appearance > header. Once I do that, the image does not link to the home page. I have tried several fixes (some i’ve found here on the forum) but I can’t seem to find a good fix for this. Is there some kind of code I can add to make the image added in the appearance > header section automatically create a link to the homepage? Basically, I need the header image to link just back to the main home page of the domain. Any suggestions?

    #24712

    Susan
    Moderator
    Post count: 7985

    Can you please include a link to your site so I can take a look.

    Do you have your site name and tagline set in Appearance > General Settings?


    Susan @ Graphically Designing I’d love to customize your website! I tweet!
    I’ve taken up the challenge! – help me answer some of the unanswered posts

    #25199

    Glade
    Participant
    Post count: 5

    Thanks for the offer of help! I ended up figuring this out…after a llllllllooooootttt of work. The header function in WordPress is not made for adding logos that link to the home page. Most of the newer (or updated) Genesis themes use the new appearance > header function, but it’s not optimal. The new themes, like the updated executive theme that i’m using does not have the option to use Dynamic Text or a Logo in the Genesis settings. Long story short, there are some significant problems with the header image function if you can’t add a link to the logo, which 99% of people are going to want to to. I’d also estimate that a very large portion of web developers do not use dynamic text in their header, they are nearly all going to use a logo. This should be easier in Studiopress themes.

    Here is how I fixed my issue in the executive theme.

    Remove or comment out this code from your functions.php file:
    /** Add support for custom header */
    add_theme_support( ‘genesis-custom-header’, array(
    ‘width’ => 1140,
    ‘height’ => 100
    ) );

    Add this code to your functions.php file:

    /** Remove Title */
    remove_action( 'genesis_site_title', 'genesis_seo_site_title' );
    /** Remove Description */
    remove_action( 'genesis_site_description', 'genesis_seo_site_description' );

    Then change your CSS file #header section from this:
    #header {
    margin: 0 auto;
    min-height: 100px;
    width: 100%;
    }

    To this:
    #header {
    margin: 0 auto;
    min-height: 100px;
    width: 100%;
    background: url(“images/logo.png”) left no-repeat;
    }

    That worked for me.

    #25200

    Glade
    Participant
    Post count: 5

    Thanks for the offer of help! I ended up figuring this out…after a llllllllooooootttt of work. The header function in WordPress is not made for adding logos that link to the home page. Most of the newer (or updated) Genesis themes use the new appearance > header function, but it’s not optimal. The new themes, like the updated executive theme that i’m using does not have the option to use Dynamic Text or a Logo in the Genesis settings. Long story short, there are some significant problems with the header image function if you can’t add a link to the logo, which 99% of people are going to want to to. I’d also estimate that a very large portion of web developers do not use dynamic text in their header, they are nearly all going to use a logo. This should be easier in Studiopress themes.

    Here is how I fixed my issue in the executive theme.

    Remove or comment out this code from your functions.php file:
    /** Add support for custom header */
    add_theme_support( ‘genesis-custom-header’, array( ‘width’ => 1140, ‘height’ => 100 ) );

    Add this code to your functions.php file:
    /** Remove Title */
    remove_action( ‘genesis_site_title’, ‘genesis_seo_site_title’ );
    /** Remove Description */
    remove_action( ‘genesis_site_description’, ‘genesis_seo_site_description’ );

    Then change your CSS file #header section from this:
    #header { margin: 0 auto; min-height: 100px; width: 100%; }

    To this:
    #header { margin: 0 auto; min-height: 100px; width: 100%; background: url(“images/logo.png”) left no-repeat; }

    That worked for me.

    #25714

    Glade
    Participant
    Post count: 5

    Never mind…logo still does not link. Back to the drawing board.

    #25732

    Charlie
    Participant
    Post count: 112

    I’ve just tried this locally, and the header I uploaded via Appearance > Header is clickable and links back to the homepage. Can you please post a link to your site so I (or someone else) can take a look at what is going on?

    Thanks.

    #27440

    kellettj
    Participant
    Post count: 2

    I’m having the exact same issue… my website is http://www.investorsheadquarter.com. Thanks!

    #28069

    headspaced
    Participant
    Post count: 3

    I can see where I’m able to upload a header, however, I am wanting to use just a logo in place of my site’s title.  Where is the option to do this?

    #45678

    StacyN
    Participant
    Post count: 5

    Exact same problem – can anyone say how this is resolved? When I replaced text with logo – it’s no longer clickable.

    My art director is getting frantic about this:

    http://jhawkwood.com/r

    #49234

    John
    Participant
    Post count: 155
Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.