add Titles to blog posts

Community Forums Forums General Discussion add Titles to blog posts

This topic is: not resolved

This topic contains 15 replies, has 3 voices, and was last updated by  rfmeier 10 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #43914

    cway
    Participant
    Post count: 23

    I’m using the Executive theme. Posts on the Blog page are missing titles. How do I add them?

    http://wp2.trentstudios.com/blog/

    Thanks!
    Cameron

    #43918

    rfmeier
    Participant
    Post count: 517

    Cameron,

    Did the ‘genesis_post_title’ default callback get removed somewhere by chance?  Usually this would be done within the functions.php file or a Genesis targeted plugin.

    Let me know.


    Ryan Meier – Web Developer @ Solid Interactive
    Twitter

    #43919

    cway
    Participant
    Post count: 23

    I found this in the functions.php file:

    //REMOVE POST TITLE
    remove_action(‘genesis_post_title’, ‘genesis_do_post_title’);

    #43920

    rfmeier
    Participant
    Post count: 517

    Cameron,

    That is preventing the post titles from displaying (most likely through out the entire site).  Commenting that out should make the post titles display again.

    Let me know the results.


    Ryan Meier – Web Developer @ Solid Interactive
    Twitter

    #43922

    cway
    Participant
    Post count: 23

    That brought back the titles in the Portfolio, which is not what I want. Blog posts titles still don’t show.

    The page called Blog is using the Blog template.

    Thanks for the quick help! I appreciate it!

    #43924

    rfmeier
    Participant
    Post count: 517

    I see.  Does the theme have a page_blog.php template file?

    Try adding the following;

    add_action(‘genesis_post_title’, ‘genesis_do_post_title’);

    Removing the action within the functions.php file is removing the title globally for all posts/pages.


    Ryan Meier – Web Developer @ Solid Interactive
    Twitter

    #43925

    cway
    Participant
    Post count: 23

    No, the theme does not have a page_blog.php file.

    I’ve got archive-portfolio.php
    functions.php
    home.php
    page_landing.php
    single-portfolio.php

    I added that coding, and added back remove_action(‘genesis_post_title’, ‘genesis_do_post_title’); but blog posts still do not have titles and posts in the portfolio do.

    #43928

    cway
    Participant
    Post count: 23

    Got it. For some reason, the version of the functions.php file in Executive I downloaded a month ago was missing some information. I downloaded a fresh copy of executive, uploaded that functions.php file and all is good.

    Thanks for your help!

    #46487

    AngelaM
    Participant
    Post count: 4

    I am experiencing this same problem. I downloaded Executive again but am not sure how to upload just the functions.php file.  I am guessing it’s through FTP. I’m almost sure enough to just do it but would like to ask so I don’t crash the site or otherwise mess things up.

    The new file size is 6,427 and the existing file size is 757, which seems strange. I’d upload to public_html/w-content/themes/genesis. Does that sound right?
    Thanks for helping this newbie!

    Angela

    #46515

    rfmeier
    Participant
    Post count: 517

    Angela,

    This should be uploaded to your child theme’s folder. The Genesis functions.php is for the framework and should not be edited.

    You can always replace the default Genesis functions.php through ftp, then upload your child theme’s functions.php file to your child theme folder.


    Ryan Meier – Web Developer @ Solid Interactive
    Twitter

    #46537

    AngelaM
    Participant
    Post count: 4

    Thanks Ryan. I replaced the Executive theme’s functions.php, and it didn’t change anything. My individual posts still don’t have titles – here’s one example. http://thebizfarmer.com/3easystepstoachievenything/ ‎ (the other posts look like they have titles because I added them into the post itself and made it a heading, but then it looks wrong on mobile as it shows titles on mobile devices.

    Also, on the blog page, the listing of posts does not contain titles either.

    What else could I look for?

    Thanks in advance!

    #46538

    rfmeier
    Participant
    Post count: 517

    Angela,

    Within Chrome tools. I found this within your style.css file;

    .entry-title {
        display: none;
    }

    Then, temporarily turning that rule off, gives this result;

    https://www.diigo.com/item/image/40chg/n93h

    This is turning off all post titles.

    I hope this helps.


    Ryan Meier – Web Developer @ Solid Interactive
    Twitter

    #46549

    AngelaM
    Participant
    Post count: 4

    Hi Ryan,

    That is exactly what I am going for. It’s basic I’m sure but how exactly do I turn off that rule? I tried deleting the entire line, deleting just the display:none, just “none” and even tried display:block and I’m not getting any changes.

    Thanks -

    Angela

    #46555

    rfmeier
    Participant
    Post count: 517

    Angela,

    Removing ‘display:none’ should suffice.

    It looks like you style.css file is cached, so the changes are not showing up.


    Ryan Meier – Web Developer @ Solid Interactive
    Twitter

    #46561

    AngelaM
    Participant
    Post count: 4

    Got it. Awesome. Thank you so much!

     

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.