Adding a Homepage – Widget Problems

Community Forums Forums Design Tips and Tricks Adding a Homepage – Widget Problems

This topic is: resolved

Tagged: , ,

This topic contains 5 replies, has 3 voices, and was last updated by  braddalton 7 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #59234

    rdonna
    Participant
    Post count: 4

    Hi all. I’m working on doing a custom theme based off of Going Green Pro. I’ve added a home.php to the site, as I need a homepage for this site. I used the home.php from Agency as a base, so that I could have a welcome, slider, and 3 home widgets under the slider, and added custom css, etc. from that. However, for some reason my widgets are appearing in the footer when I add something to the widget area. Here’s a screenshot of the original “homepage” which was just posts:

    Going Green Screenshot 1

    And here’s the screenshot of what happens if I put in the slider:

    Going Green Screenshot 2

    I’ve done a few custom versions based off Genesis themes before, and I’ve never experienced this problem. If you like, I can show you my PHP as well. Any help is welcome! Thanks!!

    • This topic was modified 7 months, 3 weeks ago by  rdonna.
    • This topic was modified 7 months, 3 weeks ago by  rdonna.
    #59618

    braddalton
    Participant
    Post count: 7442

    Could you link to your site please.

    Your CSS code may need adjusting.

    You could create a page template and use that for the home page in your Reading Settings.


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #61065

    Helen
    Participant
    Post count: 10

    Hi, Did you get the widgets to show up properly on the Home page? I am asking because I need/want to do the same thing and am having the same problem…. Thanks!

    #61076

    braddalton
    Participant
    Post count: 7442

    Here’s a tutorial a wrote which includes the working code from the Agency theme and can be tweaked to work on other themes. http://wpsites.net/web-design/create-custom-page-template-like-home-for-the-agency-theme/


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #61077

    rdonna
    Participant
    Post count: 4

    I managed to fix the problem. I had to rearrange some of the elements in the PHP templates in order to get them to display properly.

    #61078

    braddalton
    Participant
    Post count: 7442

    Please mark this as resolved. Thanks.


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Adding a Homepage – Widget Problems’ is closed to new replies.