adding my own genesis_loop is making the_content() NULL

Community Forums Forums Design Tips and Tricks adding my own genesis_loop is making the_content() NULL

This topic is: not resolved

This topic contains 2 replies, has 2 voices, and was last updated by  jdingman 1 year, 4 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #36100

    jdingman
    Participant
    Post count: 31

    I’m setting up my own loop for a specific page on my site, but as soon as I do, it makes the_content() return NULL

    remove_action ('genesis_loop', 'genesis_do_loop'); // Remove the standard loop
    add_action( 'genesis_loop', 'custom_do_loop' ); // Add custom loop

    When I comment out the remove_action above, it loads the_content() just fine.

    Thoughts?

    (Sorry, no link is available, I’m local-deving)


    Learn more about Genesis.

    WordPress News, tips, and tricks – WPForce.com

    http://wpforce.com
    #36106

    braddalton
    Participant
    Post count: 9223

    These are 2 of the best posts for creating a custom loop or archives page:

    http://www.briangardner.com/custom-archives-page/

    http://genesissnippets.com/genesis-custom-loop/


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #36160

    jdingman
    Participant
    Post count: 31

    Ah so it sounds like I need to run the loop again because I’m removing the original loop.

    I’ll give that  a shot, thanks Brad!


    Learn more about Genesis.

    WordPress News, tips, and tricks – WPForce.com

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.