Adding "secondary menu" to Modern Portfolio theme

Community Forums Forums Design Tips and Tricks Adding "secondary menu" to Modern Portfolio theme

This topic is: not resolved

This topic contains 4 replies, has 2 voices, and was last updated by  jskintauy 11 months, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #56833

    jskintauy
    Participant
    Post count: 9

    Hi All,
    I have had a lot of success (thanks to some early help here and the tutorials) modifying the Modern Portfolio theme for my use. I am almost done (yay!) but have one issue I can’t figure out. This is on a local development machine, so I can’t show it, but I will try to thoroughly describe what I want.

    On the MP homepage, there is a widget area, header right, where you can put in a custom menu. I don’t want that menu. I want the menu that appears on the other pages below the header. This seemed simple enough. I decided first to create a widget area below the header (then changed it to above the content to see if it made a difference) and put the menu there. This doesn’t work at all even though all appears good until you actually view the site. There is no evidence of the widget looking at it through Firebug and using view code.
    Next I tried doing this with an action hook with similar poor results.
    I decided to try some other ways like removing the custom menu from header right and leaving just the secondary menu, but this doesn’t work either.
    If this theme does not allow that customization (without major surgery on the parent theme…which I am not going to do) I will simply move on, but it seems like it should be straightforward and that I am missing something obvious.
    Thanks ahead for any help.

    Jim

    #56835

    braddalton
    Participant
    Post count: 8899

    The theme already includes both menus.

    I provided a screenshot this week which shows both menus on the home page as well as the header right widget with custom menu. http://www.studiopress.com/forums/topic/modern-portfolio-home-page-not-showing-navigation-menu/#post-55991

    Am i missing something?


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #56922

    jskintauy
    Participant
    Post count: 9

    Hi Brad,

    Thanks for the reply. I have put this issue off until now because I thought it was soo odd….but here it is. I get the same result as you, both menu’s appear, but If I remove the custom menu widget from the Header Right widget area, the primary menu disappears as well on the home page. So, because I think I have missed something entirely, can you verify that if you remove the widget from header right the menu below the header disappears as well on your install?

    Jim

    #56930

    braddalton
    Participant
    Post count: 8899

    That happened also when i tested it just now.

    But the other day, i had all 3 on the home page now its 2 and 3 on all other pages.

    Maybe its all the code i test stuck in the theme, not sure at the moment but i know there will be a reason.


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #56982

    jskintauy
    Participant
    Post count: 9

    Hi Brad,

    Okay, thanks for verifying I am not going crazy. Honestly, I have spent too much time on this and don’t want to let it get in the way of getting the site up. All in all, I am very happy with the whole process and I am convinced Genesis is a solid platform that I can quickly manipulate.
    If I figure out how to fix this, I will post a solution :)

    Jim

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.