Agency Pro – background problem

Community Forums Forums General Discussion Agency Pro – background problem

This topic is: resolved

This topic contains 18 replies, has 3 voices, and was last updated by  kiralytool 5 months, 3 weeks ago.

Viewing 4 posts - 16 through 19 (of 19 total)
  • Author
    Posts
  • #85980

    AC
    Blocked
    Post count: 7712

    Replace all of that with this -

    `/** Add support for custom background */
    add_theme_support( ‘custom-background’ );

    #85982

    garnetta
    Participant
    Post count: 19

    That fixed it! Thank you so much!!

    #85983

    AC
    Blocked
    Post count: 7712

    You’re welcome!

    #99104

    kiralytool
    Member
    Post count: 2

    This solution led me to this error:

    Parse error: syntax error, unexpected ” (T_ENCAPSED_AND_WHITESPACE), expecting identifier (T_STRING) or variable (T_VARIABLE) or number (T_NUM_STRING) in /home/content/p3nexnas03/96/2062196/html/wp-content/themes/agency-pro/functions.php on line 83

    Currently the site is not live and I was building it under GoDaddy…hopefully their support team can fix this issue for me without losing all my work.

    Here’s what I removed:

    //* Enqueue Backstretch script and prepare images for loading
    add_action( ‘wp_enqueue_scripts’, ‘agency_enqueue_backstretch_scripts’ );
    function agency_enqueue_backstretch_scripts() {

    //* Load scripts only if custom background is being used
    if ( ! get_background_image() )
    return;

    wp_enqueue_script( ‘agency-pro-backstretch’, get_bloginfo( ‘stylesheet_directory’ ) . ‘/js/backstretch.js’, array( ‘jquery’ ), ’1.0.0′ );
    wp_enqueue_script( ‘agency-pro-backstretch-set’, get_bloginfo( ‘stylesheet_directory’ ).’/js/backstretch-set.js’ , array( ‘jquery’, ‘agency-pro-backstretch’ ), ’1.0.0′ );

    wp_localize_script( ‘agency-pro-backstretch-set’, ‘BackStretchImg’, array( ‘src’ => str_replace( ‘http:’, ”, get_background_image() ) ) );

    }
    —-
    //* Add support for custom background
    add_theme_support( ‘custom-background’, array( ‘wp-head-callback’ => ‘agency_background_callback’ ) );

    //* Add custom background callback for background color
    function agency_background_callback() {

    if ( ! get_background_color() )
    return;

    printf( ‘<style>body { background-color: #%s !important; }</style>’ . “\n”, get_background_color() );

    }

    And here’s what I replaced it with (per the previous posts):

    `/** Add support for custom background */
    add_theme_support( ‘custom-background’ );

    I received the error and have been locked out since hitting update.

Viewing 4 posts - 16 through 19 (of 19 total)

You must be logged in to reply to this topic.