Agency Theme Mobile Responsiveness

Community Forums Forums Design Tips and Tricks Agency Theme Mobile Responsiveness

This topic is: not resolved

This topic contains 6 replies, has 3 voices, and was last updated by  hipstershaun 12 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #54315

    scaught
    Participant
    Post count: 6

    Hey, all.

    Firstly, HUGE fan of the Studiopress world. Been a long time users.

    The Agency theme is said to be mobile responsive, but when I look at the demo site on my Android (S3), the menu on the right header area is displayed in the middle of the page and the three boxes that are side by side (Eco-Friendly Solutions, Secure Data Storage, and About Our Company) are rendered as a single column.

    I ask this because a new site that I’ve designed, based on the Agency theme, is behaving the same way. It seems stubborn in its unwillingness to behave on a mobile device.

    On my Nexus 7, in portrait mode, same problem. In landscape, all is good.

    iPod: Same problem in portrait and landscape.

    The site I’m developing is here: http://vegasvideocoop.com
    Password is co!op.

    I would sure like some feedback on why both the demo Agency theme and my site are not displaying correctly on my mobile devices.

    Thanks!

    http://vegasvideocoop.com
    #54326

    Robin
    Participant
    Post count: 151

    Your site and the SP demo are both doing exactly what they are supposed to do when viewed on mobile devices. The right header menu drops down under the logo and the featured posts align vertically in order to be read better on mobile. If you don’t want that look, you can remove the media queries section of your style css.

    As I view your site, using the responsive tool (http://www.studiopress.com/responsive/?vegasvideocoop.com/) it appears your challenges are with your logo and the iframe video, neither of which are set up to be responsive.


    Need help customizing your website? Let me know at RKW Media.

    I’m taking up The Challenge by answering some of the Unanswered Posts.

    #54333

    scaught
    Participant
    Post count: 6

    Ahhhh. . .I see. I misunderstood the term responsive.

    One last question, when I did as you said, and removed all the media queries, it did exactly as you said. However, now, when I go to any page on the site, it initially looks a bit zoomed in. . .instead of showing the full width of the page. Any ideas why that would be?

    Thanks so much for your help!!

    #54388

    Robin
    Participant
    Post count: 151

    Your site looks like a normal non-responsive website. A very good one, I must add!

    It may appear zoomed if your are viewing it in the responsive tool because the tool is designed to show you how a responsive site will look on different mobile devices and your site is no longer responsive.


    Need help customizing your website? Let me know at RKW Media.

    I’m taking up The Challenge by answering some of the Unanswered Posts.

    #54393

    scaught
    Participant
    Post count: 6

    Thanks for the nice words, Robin.

    I’m seeing the zoomed-in behavior when looking at the site with any of my mobile devices; iPod, Android S3, Nexus 7.

    It’s weird.

    #54399

    Robin
    Participant
    Post count: 151

    You’re welcome.


    Need help customizing your website? Let me know at RKW Media.

    I’m taking up The Challenge by answering some of the Unanswered Posts.

    #81070

    hipstershaun
    Participant
    Post count: 5

    scaught, I think the “zoomed-in” behavior may be solved by setting the viewport size in the document head. Try adding something like <meta name=”viewport” content=”width=1180″ /> to the document head, replacing 1180 with the appropriate width for the site. You could use the Genesis Simple Hooks plugin to add the code. Hope this helps.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.