Associate Theme, slow performance 10+ seconds load time

Community Forums Forums Design Tips and Tricks Associate Theme, slow performance 10+ seconds load time

This topic is: not resolved

This topic contains 6 replies, has 3 voices, and was last updated by  David Chu 1 year ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #38750

    cwensink
    Participant
    Post count: 2

    Hello Everyone,

    I need a little help, my site at http://camcorderchris.com is loading very slowly and I don’t understand why.  When I clear my cache, then open a new Chrome window it takes nearly 10 seconds for my site to load.  Here’s what I’ve done so far to try to speed things up:

    -installed wp-optimizer database plugin to try to clean up / make the database efficient

    -installed wp smush it to compress images to make them smaller

    -reduced listing of widgets that exist on the home page to reduce database queries

    -installed and tried changing w3 super cache plugin settings to increase performance

    -implemented cloudflare for my server

    -cleaned up the site post / page previous drafts

    I have the current version of wordpress installed, and with the Genesis Framework and the Associate Theme from studiopress installed.

    The site has 10 published pages, 56 published posts, 2 sticky posts and 57 draft posts

    I have these plugins installed:

    Plugins:
    akismet
    backWP up
    Better WP Security
    ClickTale Plugin
    Google analytics for wordpress
    iContact Widget
    Jetpack for wordpress.com
    Login LockDown
    Visual Form Builder
    W3 Total Cache
    Wordpress SEO
    WP-OPtimize
    WP Smush.it

    I’d love the feedback from any wordpress experts on what I can do to increase the site load time.  I want to get to a point of having 2-3 seconds load time.

    The server is hosted on bluehost.  I have another site that I designed through a different bluehost account using the same theme, that has more graphics that loads in 3 seconds, so I don’t know why mine is so slow.

    Thanks for your input.

    Chris

    http://camcorderchris.com
    #38754

    David Chu
    Participant
    Post count: 1355

    Hi,
    Interesting tricky question. When you described slowness, I was conjuring up the usual suspects I see around here: photos that are much too big, Facebook crud being pulled in that everyone seems to want, and really bad hosting that people like to buy because it’s advertised and cheap. You have none of those, congrats! :-)

    You are pulling a fair amount of weight here with all those plugins. But nothing too crazy. And I didn’t see any Javascript errors.

    I get very good response in Firefox, but yes, I get pretty bad performance in Chrome, too. I do have one idea. I wonder if something in your site triggers Chrome’s Predict Network. You can test that by trying this out.

    Click the Chrome menu Chrome menu on the browser toolbar.
    Select Settings.
    Click Show advanced settings.
    In the “Privacy” section, deselect “Predict network actions to improve page load performance.”

    Even if that’s true, one can’t assure that one’s visitors are willing to shut that off.

    That’s my best guess. Beyond that, maybe one of your plugins is fighting Chrome somehow.

    Good luck, Dave


    Dave Chu · Custom WordPress Developer – likes collaborating with Designers

    #38831

    cwensink
    Participant
    Post count: 2

    Hey David,

    Thanks for your thoughts.  I was able to improve performance quite a bit, by doing a few things:

    1.  Disabling and Deleting Jet Pack

    2.  Installing a new plugin called WP defer javascript, which waits until the page has loaded to run all the javascript on the page

    3.  Implemented Amazon S3 for a CDN service

    The combination of those three things really sped up the performance of the site and took me from a pingdom score of 81 to 92.

    I did follow a great post by Yoast a while back that talked about statically defining resources inside of your code, so that it doesn’t have to do a database query each time for that resouce.  Here’s the post:

    http://yoast.com/speed-up-wordpress/

    I was using either the 2011 theme or a theme from organic themes and I was able to follow the content of the post exactly and that made a huge difference in load time for my site.  The problem is, the examples don’t line up to code inside of Genesis now, so I don’t know how to change things now.  Any thoughts?

    Chris

     

     

    #38851

    David Chu
    Participant
    Post count: 1355

    Chris,
    I’m afraid you’re ahead of me on all that fancy optimization stuff. I avoid having an opinion where I have little knowledge. :-)

    Although I suppose if you elaborate on what you mean by “examples not lining up”, I may be able to offer a thought. For instance, there are some hooks that are less publicized than the official documentation stuff that can come in handy for shoehorning things in here and there.

    Dave


    Dave Chu · Custom WordPress Developer – likes collaborating with Designers

    #38895

    magnify28
    Participant
    Post count: 17

    I have the same issue as Chris, similar plugins and same slow site load speed, about 10 secs.  Did similar things to optimise like adding cloudflare, deleting jetpack and have w3 total cache.

    Has not helped very much at all. Will add the CDN and see if that helps any.

     

    #56380

    cwensink
    Participant
    Post count: 2

    Hello Everyone,

    I have found the solution for this issue. The issue was with the database for bluehost. To fix the issue, I had to login to the bluehost control panel, under Database Tools, go to phpMyAdmin, then I determined which database was for my site by clicking on the database then going to the wp_options table and looking at the first table entry for siteurl. Once I had the right database, I selected all of the tables of the database, then under the tables list there is a drop down dialogue box, choose Optimize Table, then hit Go, and it optimizes all of the tables.

    This made a dramatic improvement in performance.

    Also one thing a Bluehost rep said to me is that for standard hosting accounts, theythrottle the cpu utilization and if there’s too much cpu utilization (which can happen a lot with certain caching plugins like W3 total cache) the quota is exceeded and your site will slow down from throttling. The proposed solution is to implement the WP Super cache plugin or Quick Cache plugin as an alternative. A third option is to upgrade to a Pro account or VPS server which you give you a lot more resources and efficiency.

    I hope that helps everyone.

    Chris

    #56389

    David Chu
    Participant
    Post count: 1355

    Chris,
    That’s wild. I used to routinely recommend that back in the day, and frequently did it myself. One symptom was seeing an enormous error log file that was too big to even open. But I rarely think of that anymore because recent WordPress has made strides in avoiding that from the get-go. I don’t recall the minutiae, but if memory serves, it has something to do with improvements in the handling of file locking when doing database updates.

    Of course, some hosts may vary. It may be worth seeing how up-to-date your PHP and MySQL setup is – some hosts are way behind the curve for that sort of thing. I remember seeing amazingly old versions of things on Liquidweb and Namecheap (hosting, not their domain management). Or if you have a monster-sized table, frequent care and feeding is probably a good idea.

    In any case, glad you fixed that.

    Dave


    Dave Chu · Custom WordPress Developer – likes collaborating with Designers

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.