Author page going to home page

Community Forums Forums General Discussion Author page going to home page

This topic is: not resolved

This topic contains 3 replies, has 3 voices, and was last updated by  LdyLarke 1 year, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #22103

    isolde100
    Participant
    Post count: 4

    When I click on my name (at the top of a post), instead of going to my author page, it goes to the home page. Here is the URL of my author page:

    http://www.mapplr.com/author/esme-vos/

    If you click on it, you are taken to the main page.

    I am using Genesis 1.9.1 and the Metro child theme.

    Esme

    #22180

    sanjeev
    Participant
    Post count: 34

    Looks like a redirect is setup for your author page, even the URL is not taking it to the correct page…..are you using any redirection plugin….Doesn’t looks like an issue because of genesis or Metro, some other plugin is messing it up…


    Meet me at: Make Web World

    #22234

    isolde100
    Participant
    Post count: 4

    I found the source of the problem: the WordPress SEO plugin by Yoast. When I disabled it, lo and behold, the author pages began to show up. The problem can be fixed by going to this forum page on WordPress.org where people posted their workarounds:

    http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-author-page-link-still-redirecting-to-homepage

    As of 22 Feb 2013, Yoast has not fixed the bug in his plugin.

    #25719

    LdyLarke
    Participant
    Post count: 46

    Seems to work now though. I too was having that issue. According to the wordpress.org link you posted, deselecting Disable the author archives will now show the author page correctly.

    http://www.livingwithfibromyalgia.ca/author/Shannon

    I have the Prose child theme


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.