Balance demo theme image settings

Community Forums Forums Design Tips and Tricks Balance demo theme image settings

This topic is: not resolved

Tagged: ,

This topic contains 10 replies, has 3 voices, and was last updated by  jennifergrayeb 11 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #40222

    mseledwards
    Participant
    Post count: 5

    Hiya :)
    I’m running the Balance theme on my site (http://heavenandel.com) and I’d like to have the images show up under the title, the same size as they are on the demo theme.

    From reading elsewhere here on the forum, I gather that this needs to be 600×200 but where do I need to set it as such in my theme settings? And what should I set as the thumbnail size?

    Many thanks in advance for your help,

    El

    http://heavenandel.com
    #40321

    anitac
    Participant
    Post count: 6991

    Open up your functions.php file. Look for the area for image settings. Add this in there:

    [php]add_image_size( ‘featured’ , 600, 200, TRUE );[/php]


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #40346

    mseledwards
    Participant
    Post count: 5

    Thank you :) I did that but it doesn’t seem to have done anything. I checked under the general genesis settings and see that the 600×200 is now listed as a choice for the size of featured image so it has done something, but not what I was hoping it would :)

    Any ideas what I’m missing? Thanks :)

    #40378

    anitac
    Participant
    Post count: 6991

    Open home.php and look for this:

    [php] genesis_grid_loop( array(
    ‘features’ => 1,
    ‘feature_image_size’ => 0,
    ‘feature_image_class’ => ‘align none post-image’,
    ‘feature_content_limit’ => 0,
    ‘grid_image_size’ => ‘grid’,
    ‘grid_image_class’ => ‘align none post-image’,
    ‘grid_content_limit’ => 0,
    ‘more’ => __( ‘Continue reading…’, ‘genesis’ ),
    ‘posts_per_page’ => 5,
    ) );[/php]
    Where it says “0″ for feature image size – change the 0 to the word “featured” (but without the quotes I put).


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #40379

    anitac
    Participant
    Post count: 6991

    Oh… you might need to put it like this – ‘featured’


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #40505

    mseledwards
    Participant
    Post count: 5

    Thank you so much … ‘featured’ did it for the home page.

    Not wanting to push my luck but, I was looking for something similar on functions.php (because Balance doesn’t appear to have a single.php) because now the images are showing on the home page but not on the single post page but I couldn’t see anything that might do it. Any ideas?

    #40509

    anitac
    Participant
    Post count: 6991

    The Featured Image doesn’t automatically show up at the top of the posts or pages. That is something you have to manually do.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #40510

    mseledwards
    Participant
    Post count: 5

    Ah, ok, thank you :) I’ve had themes in the past that, when you set a featured image, they showed up on the post so I wondered if this might be the same. Thanks so much for all you help :)

    Love your themes :) I almost went with your pretty theme but I needed something responsive.

    #40511

    anitac
    Participant
    Post count: 6991

    Oh, I haven’t created any of the themes. I am just a volunteer moderator for the Community Forum and do custom edits.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #40915

    mseledwards
    Participant
    Post count: 5

    Ah, sorry, I saw the 8 in your Twitter handle and though you were the lady from 8 crazy designs. My mistake. :)

    Thanks again for all you do here – much appreciated.

    #58745

    jennifergrayeb
    Participant
    Post count: 20

    I wanted to re-surface this post, as I too am having image size issues with this theme, both with my featured images in a full size post, along with the teasers (grid).

    The default functions.php included this:

    /** Add new image sizes */
    add_image_size( ‘grid’, 295, 100, TRUE );
    add_image_size( ‘portfolio’, 300, 200, TRUE );

    I added this to the end of that per the conversation above:

    add_image_size( ‘featured’ , 600, 200, TRUE );

    Yet my featured images still appear whatever size the featured image is set. My understanding was that even if the image I set as “featured” is 900×500 (making up a number), this function would resize it to 600×200. Any ideas?

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.