Blog Excerpts Keeping format from main Post

Community Forums Forums Design Tips and Tricks Blog Excerpts Keeping format from main Post

This topic is: not resolved

Tagged: , ,

This topic contains 7 replies, has 2 voices, and was last updated by  craig007 2 years, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #37312


    hoping  some can help….

    We use Genesis and have lifestyle version 1.0 - please note its a static home page site with separate blog located on the menu.

    My issue is that of when people read the blog excerpts and NOT  having any of the formatting applied in the main post stripped out in the excerpts they see etc for post which I have no idea how to prevent this happening, arghhh!

    Not sure if you have or know of a plug in that might help me as doing code is a little above my head but even willing to try pasting that in if it is fairly simple to know where specifically to place such a code and in what file it has to be in my genesis theme to do this in so I too can achieve the following:

    when people see the blog page and various excerpts for any posts, I want those blog post experts above the read more link they see to use same formatting applied in its actual main post and retain and not lose their formatting of bold, italic and several paragraphs showing, etc just as in this person who uses genesis has been able to do at :
    and the audio mp3 player to also be seen like hers we use as well we can get a thumb nail image to show ok .

    ***NOTE**Using the read more apply button in the editor does not even allow us to dictate how far to see stuff and simply applied where it wants within about 70 words each time.

    The Genesis frame work is up to date with latest version and remember the lifestyle theme 1.0  Its available widgets we have is featured post and page and featured left, right and bottom…..

    ****I tried a plugin called “Advanced excerpts” BUT, never made any difference others found hit and miss and the same not working for quite a few as well etc and it’s not been updated for two years!
    look forward to hearing back with some help

    (and on behalf of  my partner Craig):



    In the website you are referring to – she isn’t using the Except. She’s using FULL CONTENT but.. she has inserted the

     <!– More –> 

    shortcode into the body of her content to generate the Read More. If you use Full Content and insert that code, you can achieve the same effect.



    Hi anitac,

    I presume (sorry newbie here please bare with me!) to set for full content it in the reading tab under settings ….. then select radio button  “For each article in a feed, show full”

    which if so, this procedure has been done and saved etc previous to my asking for help on this hence our issue here:

    we simply cannot get it to show the full post, only about 80 words, AND what we don’t want it to do,  it  strips out  all paragraphs and formatting of any bold text, italic etc  applied in the original post (yes the image thumbnail is there ok )

    We are using lifstyle them V1.0   (bare maybe if its relevant, the home page is a static site and we have a separate blog via the menu with a couple of test posts)


    not sure if one of the file needs to have some code hence  in case you wondered in the home php file the code is this:

    <?php genesis_before_content(); ?>
    <div id=”content” class=”hfeed”>

    Side note***
    I was told simply make sure the blog is set to full post and there should be all the paragraphs you wanted any formating of bold italic etc and should you want to infact only have a few paragraphs seen and read more then you would simply apply the read more button in the text editor  over on the original post and all formatting should still also  be there -right now it does not even ass aid show the full post and foramting with out so far even adding the read more!


    any thoughts what to do here?

    Many thanks





    Jenny, please share a link to your site. It’s very difficult to assist working in the blind this way. I (we) really need to see what you have going on there.


    This reply has been marked as private.


    Jenny, the blog page you have there was created using the Blog Template. As such, those settings are found in the Genesis theme settings under Content Archives. You need to set that to how you want that page to behave.



    Please note this issue was address here back in January – Also, you are using an older version of Lifestyle. It might be better to update to the current theme.



    Good news !

    Actually just figured it out and all formatting etc works yipppe!
    We added the code snippet Susan mentioned in January which gosh somehow got overlooked and now it is added to the function.php everything works what we wanted formatting, paragraphs etc.

    Sorry about this and appreciate your patience and help!

    ****Just one thing -please*** I just  noticed when you read each main blog post it  keeps adding each time in the address url for any post after end of each title  it has  id numbers, well  we don’t want it to do this
    such as:



    typical example might look like:

    How do we go about getting rid of that  will it be over in Permerlink settings ?

    If so,  what common setting to check mark select and what code should we put to not have it do this please?

    ****(bare in mind the home page itself is s static  website and all the pages are fine and don’t do this adding id code BUT just the blog post doing this)


    Many thanks


Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.