Blog Not Showing Correctly

Community Forums Forums Design Tips and Tricks Blog Not Showing Correctly

This topic is: not resolved

This topic contains 11 replies, has 3 voices, and was last updated by  Anita 3 weeks, 4 days ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #119278

    kilerb
    Participant
    Post count: 56

    For some reason, I’m having multiple problems with the blog on this site.
    Here are the issues…
    • The title isn’t showing at all.
    • I’d like to have a 150×150 featured image to the right of the story. (Just like I have on freecomedyshows.com which is the old version of streamline I believe.)
    • I’d like to show excerpts. When I click that option, it works, but there’s no link to see the rest of the story. Just 3 dots in parenthesis… (…) that don’t link. I’d like it to say “Read More” And the title should link to it too, but that’s not showing.

    Thanks!

    http://daledymkoski.com/
    #119287

    miija
    Participant
    Post count: 61

    Here is help with the Read More link.

    http://wpsites.net/web-design/customize-read-more-tag-link-excerpt/

    As for the blog excerpts, try looking at Bob’s tutorial on your theme under Content Archives:

    http://bobwp.com/streamline-pro-child-theme-tutorial/

    If this isn’t what you want then a little bit of custom coding will be needed, or possibly tweaking the CSS

    Not sure about the title not showing up.

    • This reply was modified 1 month ago by  miija.
    • This reply was modified 1 month ago by  miija.
    #119289

    Anita
    Blocked
    Post count: 7712

    For the titles, I can’t seem to find what’s wrong. I’ve looked through the code. By any chance do you have the Genesis Title Toggle plugin installed because that turns the titles on and off.

    I see the 150×150 to the left and also to the left on the other website. I don’t see them to the right

    Excerpts do not show the [Read More] but if you want that – go to Genesis > Theme Settings. Scroll down to Content Archives and you can set it to “Content Limit” – add number there of maybe 300 and save it. Then you will get the result you want.

    I hope I interpreted what you were asking for.

    #119292

    kilerb
    Participant
    Post count: 56

    I meant to the left for the 150×150 image. On his site that’s not a featured image. I just embedded it there and it kind of looks like one for now. I’d like an excerpt with a featured 150×150 image like on the freecomedyshows.com site. :)

    #119293

    Anita
    Blocked
    Post count: 7712

    What do you have selected under Genesis > Theme Settings > Content Archives? Have you selected and image and content limit?

    #119294

    Anita
    Blocked
    Post count: 7712

    Poop, I forgot. Streamline uses that huge Featured Image and not the thumbnails. You don’t have any Featured Images set, right? You have to hack the functions.php file. I just did this for a client! How could I forget.

    Back up your functions.php file. Then look for this in the functions.php and REMOVE IT.

    //* Remove default post image
    remove_action( 'genesis_entry_content', 'genesis_do_post_image', 8 );
    
    //* Add post image above post title
    add_action( 'genesis_entry_header', 'streamline_post_image', 1 );
    function streamline_post_image() {
    
    	if ( is_page() || ! genesis_get_option( 'content_archive_thumbnail' ) )
    		return;
    	
    	if ( $image = genesis_get_image( array( 'format' => 'url', 'size' => genesis_get_option( 'image_size' ) ) ) ) {
    		printf( '<a href="%s" rel="bookmark"><img class="post-photo" src="%s" alt="%s" /></a>', get_permalink(), $image, the_title_attribute( 'echo=0' ) );
    	}
    	
    }
    
    

    Then add this:

    //* Add default post image 
    add_action( 'genesis_entry_content', 'genesis_do_post_image', 8 ); 
    
    #119295

    Anita
    Blocked
    Post count: 7712

    Here’s the demo I did for the other client. So it works.

    #120103

    kilerb
    Participant
    Post count: 56

    Hi Anita… Thanks! I haven’t had a chance to look at this until now. The demo you linked was in maintenance mode the day you sent that and still is. Just so you know :)

    Where do you set how many characters an excerpt will show? It’s not filling up all the space and I think it will look better with more.

    • This reply was modified 3 weeks, 4 days ago by  kilerb.
    • This reply was modified 3 weeks, 4 days ago by  kilerb.
    • This reply was modified 3 weeks, 4 days ago by  kilerb.
    • This reply was modified 3 weeks, 4 days ago by  kilerb.
    #120107

    kilerb
    Participant
    Post count: 56

    Actually, I found the excerpt character length in the link above. I actually added 3 pieces of code to the functions.php… Only 1 of them seemed to work (The one that states how many characters the excerpt should be…) The other 2 didn’t seem to work. The [...] still remains rather than the <read more> with a link. Here’s the code I used…

    add_filter( 'the_content_more_link', 'customize_wp_read_more_link' );
    function customize_wp_read_more_link() {
        return '<a class="more-link" href="' . get_permalink() . '">[Read More]</a>';
    }
    
    add_filter( 'get_the_content_more_link', 'modify_read_more_link_text' );
    function modify_read_more_link_text() {
        return '... <a class="more-link" href="' . get_permalink() . '">[Read The Entire Article]</a>';
    }
    
    add_filter( 'excerpt_length', 'change_excerpt_length' );
    function change_excerpt_length($length) {
        return 65; 
    }
    #120117

    Anita
    Blocked
    Post count: 7712

    You didn’t need to do that – it’s controlled under Genesis > Theme Settings. I took it off maintenance – http://staging6.cre8tivediva.com/?page_id=79. I didn’t add any extra code other than the thumbnail code.

    #120258

    kilerb
    Participant
    Post count: 56

    Hi Anita… I went to Genesis>Theme Settings. I don’t see anything regarding the <read more> option. I see excerpt or full post… Which I changed to excerpt. Everything looks great now, But the posts all still end with [...] rather than a link to <read more> Isn’t that what that tutorial posted above is about? I added those codes to the functions.php like it said… And you said I didn’t have to? I’m confused! Hahahah :)

    #120260

    Anita
    Blocked
    Post count: 7712

    Your code may be confusing Genesis. If you use Excerpt you will get the [...]. If you use Content Limit and add, say 300 to that, the [Read More] will show up.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.