Blogpost Read More directs to a 404 error

Community Forums Forums General Discussion Blogpost Read More directs to a 404 error

This topic is: resolved

This topic contains 8 replies, has 2 voices, and was last updated by  jennsearls 1 year, 11 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #12223

    jennsearls
    Participant
    Post count: 11

    I’m a newbie finding my way around wordpress. All was working fine as I wrote and published a test post this evening. But as I continued to work with the site settings and plugins and widgets I broke something. Now when you see my first blog entry on the home page http://jennifersearls.com and click read more you get a 404 Error Page Not Found. But you see my name listed in the site map and by clicking that the correct page comes up. How can I fix this so the front page read more takes me directly to this page? Many thanks!

    #12232

    Bill Murray
    Participant
    Post count: 575

    The problem is not with your read more. Note that your post title also generates a 404 error.

    For a first step, try re-saving your permalinks – without changing them. See Settings->Permalinks.

    When you save your permalinks even without changing them, that does something that is referred to as flushing your re-write rules. This is a common debugging technique for broken links.

    If that doesn’t work, try deactivating all of your plugins, and then re-save your permalinks. After doing that, activate your plugins 1 by 1 and check the post URL after each activation. If you get a 404 error, you know that plugin is producing a problem, so you’ll need to keep it deactivated until you get a better handle on why it’s not working with your configuration.


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #12235

    jennsearls
    Participant
    Post count: 11

    Thank you for your help! I tried the simple permalink re-save. That didn’t fix it but I had actually changed the permalink setting earlier this evening by toggling to the post name option. So just now I toggled it back to the default and it works correctly again. Is it not possible to have a post name permalink for some reason I’m not aware of yet?

    #12238

    Bill Murray
    Participant
    Post count: 575

    Sure, but let’s make sure you did it correctly. Choose a Custom Structure for your permalink and put this in the textbox:

    /%postname%/

    Then save.

    If you had a bad entry there, that would create a problem.

    Keep in mind that when you use this permalink setting, you are always free to create a manual permalink. For example, you could make the permalink for your post /holding/

    Short, keyword rich permalinks with keywords close to the left (in a LTR language) are best. Your post title might make for interesting reading, but it may not bring in visitors from organic search. Therefore, some choose to use a creative title as you have done because that captures a reader’s attention, but then change the permalink to something that is different from the title and more likely to help that post rank and bring traffic.


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #12239

    jennsearls
    Participant
    Post count: 11

    I really appreciate your help and also your insight into permalinks as they drive traffic. I copy/pasted

    /%postname%/

    in the custom permalink text box and got the same page not found error as before.

     

    When I save it the text box field stays populated with /%postname%/

    but the toggle button automatically moves up to “post name”

    Any further thoughts?

     

    #12242

    Bill Murray
    Participant
    Post count: 575

    I always have further thoughts. They just might not be on topic. :)

    Set your permalink structure to: /%category%/%postname%/
    Save
    Test the post URL
    Go back and change your permalink to /%postname%/
    Save
    Test

    What is your host? Are you on Windows or Linux hosting? What’s happening here is that WP needs to adjust your rewrite rules, and it’s not working perfectly. The switch to a permalink structure you don’t want hopefully will cause WP to rewrite its rules and then allow you to choose a structure you do want. (Note: I’m only recommending this because you’re just getting started on your site; it wouldn’t be a technique I’d use if you had hundreds of posts and lots of traffic.) If this doesn’t work, you may want to reach out to your host and make sure that a) WP can write to your .htaccess file (if Apache) and b) if it can, what re-write rules WP creates once you set /%postname%/ as your structure.

    Oops! Forgot to mention another possible cause: you need mod_rewrite installed (an Apache module). You can ask your host if that’s installed and working.

    Post back with the results.


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #12243

    jennsearls
    Participant
    Post count: 11

    This worked perfectly:

    Set your permalink structure to: /%category%/%postname%/
    Save
    Test the post URL

    But following with this produced the same results as before:

    Go back and change your permalink to /%postname%/
    Save
    Test

    I’m using dreamhost. I’ve had great experience with their customer service. Does it seem that I should now take your questions to them?

    Again – thank you!

     

    #12277

    Bill Murray
    Participant
    Post count: 575

    Yes, your next step is contacting your host. It’s more than likely a problem with your .htaccess file. It could be a) the permissions for the file or the folder, b) it’s missing a line like Options +FollowSymlinks, c) mod_rewrite isn’t installed or d) something else.

    Try to avoid having index.php in the permalink. That’s not a good outcome.

    It’s a common problem so they should be able to sort it out for you. Post back with the results.


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #12901

    jennsearls
    Participant
    Post count: 11

    Bill, thank you so much for your time and insight on this getting started project of mine. In some back and forth work with my hosting service this was the end story:

    “I tested it out and this is really weird. It works for new posts, but not
    your old one. I changed the permalink url from

    http://www.jennifersearls.com/what-are-we-holding-onto-sam/

    to

    http://www.jennifersearls.com/what-are-we-holding-onto-sam1/

    and it worked. I am not certain as to why this is happening. I would contact WordPress.org and see if they have any suggestions.”

     

    Because new posts seem to work as I expect, I’m going to just move along. Again! thank you for your help.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.