Can't change "continue reading" text

Community Forums Forums Design Tips and Tricks Can't change "continue reading" text

This topic is: not resolved

This topic contains 5 replies, has 3 voices, and was last updated by  JanHoek 4 months, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #107936

    alfredo
    Participant
    Post count: 6

    Hi!

    I added the code snippets at http://my.studiopress.com/snippets/post-excerpts/#content-more-link to my functions file but changes are not applied to my site. Basically I want the “continue reading” text to read “more” instead.

    What am I missing? The code below is what I added to functions.php

    //* Modify the WordPress read more link
    add_filter( 'the_content_more_link', 'sp_read_more_link' );
    function sp_read_more_link() {
    	return '<a class="more-link" href="' . get_permalink() . '">[more]</a>';
    }
    //* Modify the Genesis content limit read more link
    add_filter( 'get_the_content_more_link', 'sp_read_more_link' );
    function sp_read_more_link() {
    	return '... <a class="more-link" href="' . get_permalink() . '">[more]</a>';
    }

    Thanks for your help!

    http://www.spanishpicturedescription.com/
    #107978

    braddalton
    Participant
    Post count: 10253

    What settings are you using in Genesis > Theme Settings > Content Archives?


    #107979

    alfredo
    Participant
    Post count: 6

    Thanks for your reply. Please see here http://postimg.org/image/kslk8jnhz/

    Thanks!

    • This reply was modified 4 months, 3 weeks ago by  alfredo.
    • This reply was modified 4 months, 3 weeks ago by  alfredo.
    #107985

    braddalton
    Participant
    Post count: 10253

    Tested and works.

    Please copy ALL the code from the view raw link and paste it at the end of your child themes functions.php file using a text editor like Notepad++

    Remove the other snippets you added.

    Works when using the content limit.


    #108353

    alfredo
    Participant
    Post count: 6

    Hi, thanks for your reply.
    I’m still having some issues.

    I’m not using the content limit now. (please see pic: http://postimg.org/image/uzz6m1k4n/)
    I’m using this snippet:

    //* Modify the WordPress read more link
    add_filter( ‘the_content_more_link’, ‘sp_read_more_link’ );
    function sp_read_more_link() {
    return ‘[more]‘;
    }

    I want the “continue reading” text to read “more”, this is working on the homepage for the main post but not for the others posts. (please check the url in my OP).

    What am I doing wrong?

    Thanks!

    #108467

    JanHoek
    Member
    Post count: 214

    If you use the Excerpts, try this instead of the one you use

    // Add Read More Link to Excerpts
    add_filter('excerpt_more', 'get_read_more_link');
    add_filter( 'the_content_more_link', 'get_read_more_link' );
    function get_read_more_link() {
       return '...&nbsp;<a href="' . get_permalink() . '">[Read&nbsp;More]</a>';
    }

    Hi, my name is Jan Hoek. Sure, they all say I have a big head, but I like to think it’s way too small for all my ideas.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.