Change post pagination page 1 2 3 in elven40

Community Forums Forums Design Tips and Tricks Change post pagination page 1 2 3 in elven40

This topic is: not resolved

This topic contains 17 replies, has 2 voices, and was last updated by  SoZo 1 year, 5 months ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #17321

    Graywolfsurvival
    Participant
    Post count: 13

    I’ve been looking everywhere for this answer so I hope someone can help. I have the eleven40 theme at http://graywolfsurvival.com

    The post pagination (where the <!–nextpage–> code displays) shows as ‘Page: 1 2 3′ etc. It’s WAY too small and people keep missing the fact that my posts are more than one page long.

    How do I at least make the font bigger and change the color, if not outright customize it? This is driving me crazy now. I’d obviously rather edit the eleven40 pages but at this point, I’ll do anything.

    #17426

    SoZo
    Moderator
    Post count: 1573

    Where do you have the post pagination?


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

    #17438

    Graywolfsurvival
    Participant
    Post count: 13

    It’s at the bottom of every large post, such as http://graywolfsurvival.com/1215/how-to-read-people/ , right under the sharing icons before the comments.

    I thought I had it fixed this morning when I changed the font in the .navigation section of style.css from 14 to 20 to at least do something but now when I look at the site, it’s still small.

    #17441

    SoZo
    Moderator
    Post count: 1573

    It’s not wrapped in a “navigation” class not sure why that would have worked. You should be able to target it using p.pages though.


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

    #17442

    Graywolfsurvival
    Participant
    Post count: 13

    This is what .navigation shows at the moment:

     

    /* Post Navigation
    ———————————————————— */

    .navigation {
    overflow: hidden;
    padding: 20px 0;
    width: 100%;
    }

    .navigation li {
    display: inline;
    }

    .navigation li a,
    .navigation li.disabled,
    .navigation li a:hover,
    .navigation li.active a {
    background-color: #444;
    border: none;
    color: #fff;
    font-family: ‘Oswald’, arial, serif;
    font-size: 20px;
    padding: 5px 12px;
    }

    .navigation li a:hover,
    .navigation li.active a {
    background-color: #ed702b;
    border: none;
    text-decoration: none;
    }

    #17444

    Graywolfsurvival
    Participant
    Post count: 13

    Hmm. I’m still pretty new to hacking into this stuff. Where would I find p.pages? I don’t see that in style.css anywhere.

    #17452

    SoZo
    Moderator
    Post count: 1573

    Anytime there’s a rule that you need that isn’t already in the style sheet you’ll need to add it.


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

    #17454

    Graywolfsurvival
    Participant
    Post count: 13

    lol. ok. A little help?

    What would be the code that I would need to add to increase the font of the Page: 1 2 3 from the current small size to something bigger? Where would I put this?

    #17461

    SoZo
    Moderator
    Post count: 1573

    Do you understand CSS syntax? The font-size property controls text size and p.pages would be your selector, so something like p.pages { font-size: 20px; } and CSS cascades so add it anywhere below the default font-size rule.


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

    #17464

    Graywolfsurvival
    Participant
    Post count: 13

    Well, I’ve tried it in a couple of different places on the sheet, and even made it the last line of the style.css. I guess I’m too stupid to figure this out with the guidance I’ve been given. It’s not working.

    #17465

    SoZo
    Moderator
    Post count: 1573

    I’m not seeing it in your style sheet anywhere. Do you have a caching plugin enabled or are you using Cloudflare or a CDN service?


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

    #17467

    Graywolfsurvival
    Participant
    Post count: 13

    I have w3tc and cloudflare CDN but I’ve cleared out both every time I try.

    At this moment, I have p.pages { font-size: 20px; } placed as the last line in style.css of eleven40 and cleared all my cache and the CDN cache.

    #17468

    SoZo
    Moderator
    Post count: 1573

    Still not showing up. You may need to wait a bit.


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

    #17471

    Graywolfsurvival
    Participant
    Post count: 13

    It may still be cached in the cloud sharing network then if I’ve actually done it correctly. I’ll give it a day and pop back in if it doesn’t work or report that it did.

    #17573

    Graywolfsurvival
    Participant
    Post count: 13

    It appears as though the font size has finally changed. Thank you for pointing that out. This caching thing drives me crazy sometimes.

    I think the biggest problem I’m having is that the GD stars and the social icons are above the pagination so after people finish reading the last sentence, they see those and are still going to miss that there’s a next page.

    For me to put the pagination immediately after the last paragraph and before the GD stars, am I going to have to edit the core Genesis file somewhere or is this possible somehow in the eleven40 page(s)?

     

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.