Change the language for comment form

Community Forums Forums Internationalization and Translations Change the language for comment form

This topic is: not resolved

This topic contains 11 replies, has 4 voices, and was last updated by  pressdeamon 3 months, 1 week ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #108132

    ganee
    Participant

    Hi,

    Can anyone guide me on how to change the language for the comment labels under each post?



    WP Developer @ Press9

    #108151

    MortenK
    Participant

    Hi Ganee,
    I suggest you install the plugin Genesis Translations from the WordPress Repo.

    http://wordpress.org/plugins/genesis-translations/

    If your content is in more than one language I suggest you use the WPML plugin.
    http://www.wpml.org

    #108183

    ganee
    Participant

    Hi MortenK,

    I had a look at the plugin earlier. I need to change it to Malay and the language file is not completed yet. Do I need to fill it all up and only then I can download the PO and MO file? Or is there another way for me just to do changes for that set of string?


    WP Developer @ Press9

    #108292

    MortenK
    Participant

    Well, the WPML plugin has string translation built in and this is probably the easiest way to go, but it has a $79 price tag.

    You can also use Poedit, here is a guide..

    Or you can contribute to the Studiopress translations here and then download the .po/.mo files

    #111780

    pressdeamon
    Participant

    I’m having the same problem translating Going Green Pro to BR Portuguese. I installed the plugin and it translated almost the whole theme, except for the comment area. I edited the .po file, but the comments fields remain in English. I don’t know what else to do… (these strings are not hard coded anywhere)

    #112078

    MortenK
    Participant

    Genesis Translations plugin translates the Framework, not the child theme.
    Some childthemes has strings that is not included or changes strings in the framework.
    If that’s the case here you need to edit the string in the child theme directly or use the Codestyle Localization and the Codestyle Localization Preserver plugins.

    #127534

    misura
    Member

    pressdeamon

    Editing the .po file is not enough, you must generate the .mo from the .po with your updates.

    You’ll need a tool to do that:

    https://make.wordpress.org/polyglots/handbook/tools/

    • This reply was modified 5 months, 3 weeks ago by  misura.
    • This reply was modified 5 months, 3 weeks ago by  misura.
    #127536

    misura
    Member

    MortenK

    I downloaded and installed Genesis Translation plugin and activated.
    I updated my wp-config.php to

    define(‘WPLANG’, ‘pt_BR’);

    I see that “You are here” is in the pt_BR:

    wp-content/plugins/genesis-translations/genesis-translations/pt_BR.po:msgid “You are here: ”
    wp-content/plugins/genesis-translations/genesis20/pt_BR.po:msgid “You are here: ”

    With the appropriate translation.
    Grep also says the binary mo’s match.

    But when I view the page:

    http://stage.luciana.misura.org/2014/09/27/dia-de-princesa-na-disney-bibbidi-bobbidi-boutique/

    It still says “You are here” in english.

    I tried with both the genesis theme selected and with the Lifestyle-pro theme.

    Ideas?

    #127723

    MortenK
    Participant

    @misura @pressdeamon:

    You generate the .mo file from within Codestyle Localization.

    • This reply was modified 5 months, 2 weeks ago by  MortenK.
    • This reply was modified 5 months, 2 weeks ago by  MortenK.
    • This reply was modified 5 months, 2 weeks ago by  MortenK.
    • This reply was modified 5 months, 2 weeks ago by  MortenK.
    #127724

    MortenK
    Participant

    @misura:

    Are you using a cache plugin?
    If so, either flush your cache or disable it.

    • This reply was modified 5 months, 2 weeks ago by  MortenK.
    • This reply was modified 5 months, 2 weeks ago by  MortenK.
    #127785

    misura
    Member

    MortenK

    The .mo’s are already there.

    No cache, so nothing to disable/flush.

    I tried copying the files into the them’s language folder, still no dice.

    What am I doing wrong?

    #135057

    pressdeamon
    Participant

    I’m still struggling with this… Both translation plugins won’t do anything at all. I also edited the .mo file inside the child theme’s folder, nothing changes and the comment fields are not available to be translated. Also “filed under” and “tagged with” are available in the .mo file, translated, but still show in English. The only fields I managed to actually permanentely change (and will survive WordPress updates) are changes I added to the function file, but I can’t find the correct codes for everything I need to change. This is very frustrating!

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.