Custom Fields?

This topic is: resolved

Tagged: 

This topic contains 11 replies, has 4 voices, and was last updated by  dustin100 1 year, 9 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #18968

    dustin100
    Participant
    Post count: 12

    Hey, I’m using the magazine theme. I currently add my source at the bottom of every post, which looks like this “[via-WebsiteLink]”. The only problem is when someone shares the link, it is included with the description. I don’t want this to happen. What is the best option to fix this, costume fields?

    Thanks for the help

    #21408

    cdils
    Participant
    Post count: 421

    Can you post a link? I’m not clear on what’s happening, but I don’t think custom fields are the solution.

    Cheers,

    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I host a weekly Genesis-focused podcast called Genesis Office Hours. I tweet @cdils.

    #23318

    dustin100
    Participant
    Post count: 12

    http://sometimesthingshappen.com/

    When you visit just hit the FB share button, you’ll see the “via-SiteLink” show up in the description.

    Thanks for the reply!

    #23323

    cdils
    Participant
    Post count: 421

    Oh, okay! Which plugin are you using to generate those share buttons? There should be settings for the plugin that allow you to disable the “via…” part. In other words, it’s not an issue with your theme, it’s an issue with your social sharing plugin. :)


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I host a weekly Genesis-focused podcast called Genesis Office Hours. I tweet @cdils.

    #23336

    dustin100
    Participant
    Post count: 12

    So, I use ShareThis but, I don’t think that is the issue.  I understand why it shows up in the description, because I put “via-” in the text field of the post.  What I’m trying to figure out, is if I can keep the “via” in roughly the same place, without putting it in the text field. Below is a sample of one of my posts. Hopefully this helps clear things up.

    <code>

    <div class=”video-container”>
    <iframe width=”580″ height=”326″ src=”http://www.youtube.com/embed/mhlz7y_llb4″ frameborder=”0″ allowfullscreen></iframe>
    </div>
    <br>
    <p>
    The Real Genius trailer recut in the style of a M. Night Shyamalan movie.
    </p>

    [via-<a href=”http://www.youtube.com/user/dondrapersayswhat?feature=watch” title=”dondrapersayswhat”>dondrapersayswhat</a>]

    </code>

     

    Thanks again for the help

    #23375

    cdils
    Participant
    Post count: 421

    Heya!

    What do you mean by “text field of the post”? The post content area? Sorry I’m slow to understand and not being very helpful. :(

    Carrie


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I host a weekly Genesis-focused podcast called Genesis Office Hours. I tweet @cdils.

    #23381

    dustin100
    Participant
    Post count: 12

    Sorry, I’m not explaining this clearly.  Here is a screenshot  if you can’t see it, try this.  http://tinypic.com/r/2w3w8q0/6

    #23386

    cdils
    Participant
    Post count: 421

    Okay, I see what you’re saying – thanks for the screen shot. I don’t know what the answer is though. Since you’re using a ShareThis shortcode to generate the link, I think you’ll need to troubleshoot options with that plugin to get the answer. Even if you used a custom field to output the shortcode somewhere else on the page, you’d have the same issue.


    Have you been helped in this forum? Pay it forward and answer someone else’s question. I bet you’ll know the answer to at least one question. :)

    I host a weekly Genesis-focused podcast called Genesis Office Hours. I tweet @cdils.

    #23390

    dustin100
    Participant
    Post count: 12

    Not what I wanted to hear but, thanks for looking into it for me.  I’ll mess around some more and see what I can do. If I happen to find the answer/ fix, i’ll post it here.

    #23421

    ramseyp
    Participant
    Post count: 99

    @dustin100

    If you’re saying you don’t want [via-XXXX] to show up when someone shares the post, that bit of text will have to be inserted by some other method. Placing it in the post’s content editor makes it part of the content body, so it gets shared along with the rest of the post’s content.

    A custom field would work, along with editing the theme’s functions.php file so it’s placed just under your post’s content or somewhere else you prefer.

    If you’re familiar with the More Fields plugin, you could try using that to create the custom field. Getting its output into your blog or single post depends on how familiar you are with Genesis’ hooks.

    Pat


    #23427

    Hard Boiled Greg
    Participant
    Post count: 88

    Hi,

    Did you get this resolved?

    If you want to add the source via a custom field, you can post this to your functions.php file:

    [php]// Add custom field for content source after content
    function hbg_source_cf() {
    genesis_custom_field(‘source’);
    }
    add_action( ‘genesis_after_post_content’, ‘hbg_source_cf’, 8 );[/php]

    Then on your post edit screen under “Add New Custom Field” enter “source” (without quotes) for the Name and your link code (with via-) for the Value.

    I haven’t tested it with your sharing plugin to confirm it leaves out the content of this field.

    Let me know how this works out for you.

    Hard Boiled Greg


    Website: Hard Boiled Greg Twitter: @hbgreg

    #23429

    dustin100
    Participant
    Post count: 12

    Thank you everyone for the help! I’m still leaning custom fields..   @Hard Boiled Greg, this is exactly what I was looking for. It works perfectly.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.