Custom Header Not Changing

Community Forums Forums General Discussion Custom Header Not Changing

This topic is: resolved

This topic contains 6 replies, has 4 voices, and was last updated by  Carla 1 year, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #45533

    Godfather
    Participant
    Post count: 11

    Ok, playing with the Metro Child Theme and I have uploaded a custom header.

    Oddly enough, no change to the header will take affect. (Uploading new header, etc).

    I even deleted the old header from the media file….but it still shows.

    I the tried from remote servers, cleared cache, etc etc.

    Any ideas would be helpful.

    http://www.VideoGenesisRevealed.com
    #45541

    rfmeier
    Participant
    Post count: 597

    Hello,

    From investigating with Chrome, I can see WordPress is setting the default header;

    [css]
    #header {
    background: url(http://videogenesisrevealed.com/wp-content/uploads/2013/06/VideoGenesisLaunch.png) no-repeat;
    }[/css]

    The theme style.css is also specifying the header on 3 different elements;

    [css]
    /* line ~553 */
    .header-image #title,
    .header-image #title a,
    .header-image #title-area {
    background: url(images/VideoGenesisStart.png);
    display: block;
    float: left;
    min-height: 87px;
    overflow: hidden;
    text-indent: -9999px;
    }[/css]

    Note: The image url may look goofy as the board are parsing url links.

    The reason you do not see a change in the header when uploading is because the child elements .header-image #title-area > .header-image #title > .header-image #title-area a are sitting in from the the uploaded background.

    I hope this helps.


    #45638

    Godfather
    Participant
    Post count: 11

    Thanks Rfmeier,

    I actually had to delete the header in the CSS file.

    The best I seem to be able to do is get it back to the “Text” format  (which brings in an ugly red background behind the header).

    When I try and upload the new header (in the custom header section in WP), nothing happens.

    Really weird. Stuck with text for now.

    Anyone else have issues on the custom header on this theme?

    #45679

    Godfather
    Participant
    Post count: 11

    If I run text, it puts the normal text into the “redish” box.

    If I turn the text portion off (in favor of choosing a header) the red color goes accross the entire header (but does not show the custom header.

    If I have the BOTH on, the custom header shows up AND the text box shows..

    Go figure…

    #45741

    Godfather
    Participant
    Post count: 11

    OK, here is the fix…

    Find this
    .header-image #title a {
    background: none;
    padding: 0;
    }

    Make this change
    .header-image #title a {
    background-color: transparent !important;
    padding: 0;
    }

    Then upload your header image.

    #47242

    cfaulkner
    Participant
    Post count: 1

    THANK YOU Godfather!!!

    Before your fix, I could only see my custom header when using the “Default” color settings (Gensis > Theme Settings > Color Style = Default) on the Metro theme. When I chose one of the color themes(Gensis > Theme Settings > Color Style = Blue/Green/Orange/Pink/Red) or my own custom color theme, the chosen color appears in place of the custom header. Now I can see my header.

    Chris

    #52463

    Carla
    Participant
    Post count: 15

    Thank you Godfather!!! You saved me a lot of time and headaches. I was having the exact same problem and I didn’t know the code for transparency, but now it is fixed. Thank you for sharing.

    • This reply was modified 1 year, 4 months ago by  Carla.
    • This reply was modified 1 year, 4 months ago by  Carla.
Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Custom Header Not Changing’ is closed to new replies.