Dropdown Menu Breaks in iOS

Community Forums Forums General Discussion Dropdown Menu Breaks in iOS

This topic is: not resolved

Tagged: , , ,

This topic contains 5 replies, has 2 voices, and was last updated by  Mealtog 1 month, 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #115614

    Mealtog
    Participant
    Post count: 431

    ok, this is getting a little odd. While developing the site under 2 version of Genesis ago, the dropdown menu was not clickable in Executive Pro when logged in as an Admin under iOS 7 (iphone 5). Did not think much of this as support knows the issue and has no fix. It was only affecting Admin users. Theme is Executive Pro.

    Doing some testing today (current Genesis build 2.1.2) using a Subscriber account and sure enough, no menu items are clickable either.

    Has anyone ran into this? I cannot test a non-subscriber as the site is behind the Coming Soon plugin for development. How do I fix this?

    • This topic was modified 1 month, 4 weeks ago by  Mealtog.
    • This topic was modified 1 month, 4 weeks ago by  Mealtog.
    • This topic was modified 1 month, 4 weeks ago by  Mealtog.
    • This topic was modified 1 month, 4 weeks ago by  Mealtog.
    #115628

    Mealtog
    Participant
    Post count: 431

    ok, I dug up my old post on this forum and there were no fixes. I am able to confirm that the admin bar is the cause of the Dropdown menu. Once I disable it, problem went away. Had to try some code to get rid of the admin bar for mobile users. This is not the best fix as mobile users, even admins and authors do not have access to the admin bar anymore.

    Who else a better solution?

    #115885

    Tom
    Participant
    Post count: 891

    (By dropdown menu, I assume that you mean the Genesis nav menu with submenu items.)

    Could this be related to your theme alone? Or browser?

    I have been able to login as both admin and subscriber to a Genesis 2.1.2 site with both an iPhone 4s and iPad Mini, each running iOS 7.0.6. The browser in each case was Safari. The themes used were Focus Pro and Metro Pro.

    The only (significant) code that may be different is from this thread (that I see now you have visited):

    http://www.studiopress.com/forums/topic/sub-menus-not-accessible-android-devices/#post-107093

    In that thread you said For iOS, not just the submenu but the dropdown menu (primary) is not accessible for admin users on Metro Pro. Do you mean that the whole of the primary menu cannot be accessed by tap/touch on an iOS device? Or does only the dropdown portion that reveals a submenu not apppear (not dropdown)?

    If you like I can list the plugins, etc from my test site.


    Choose your next site design from over 300 Genesis themes.
    Updates via GenesisThemes.ca | Twitter | Google+ | Tumblr

    #116628

    Mealtog
    Participant
    Post count: 431

    At this point, I just removed the admin bar for mobile devices. It’s odd, it started with just the admin account. This was confirmed by support a while back it may be a conflict with Genesis or Metro Pro and WordPress core and how it shows the admin bar itself. Now, after a few WP and Genesis updates, all accounts are effected.

    Odd how you can access them on your end. Like you said, maybe it’s a plug in conflict somewhere? Not sure I want to dig through this anymore. Took so much time and not even support could solve the problem.

    When I say the problem exists, I mean if there is a drop down menu (ie sub menu), you try to click on a sub-menu, it onyl activates what is behind the menu as if the submenu does not exists. On a phone, a submenu would normally hover over a primary menu fiven the layout. You end up always clicking on the primary menu item that is behind the sub menu. Can you try this on your end to make sure we are on the same page?

    • This reply was modified 1 month, 2 weeks ago by  Mealtog.
    • This reply was modified 1 month, 2 weeks ago by  Mealtog.
    • This reply was modified 1 month, 2 weeks ago by  Mealtog.
    • This reply was modified 1 month, 2 weeks ago by  Mealtog.
    #116635

    Tom
    Participant
    Post count: 891

    Here, the sub-menu selections (Dashboard, Themes, Customize, Widgets, etc.) do launch to the expected screens.

    Unfortunately I have only Android tablet to test with tonight (but I recall these also working properly on the iPad I used earlier, also with an Admin account) On the Android I have used Chrome and also the default browser.

    Your symptom sound similar to what happens when — without the benefit of the hoverIntent script — an Android user attempts to view a Genesis nav-menu sub-menu item list (the primary menu item is selected when it is an active link item, not a placeholder # item)

    Active plugins are:

    • Akismet
    • Genesis Simple Sidebars
    • Genesis Toolbar Extras
    • Genesis Visual Hook Guide
    • iThemes Security
    • Ultimate Coming Soon Page

    Choose your next site design from over 300 Genesis themes.
    Updates via GenesisThemes.ca | Twitter | Google+ | Tumblr

    #117468

    Mealtog
    Participant
    Post count: 431

    Wow, thanks for going to great lengths to test this. Now I see why we are not seeing the same thing. I was referring to the Menu inside the site ie. Category #3. When these have sub menus, my iPhone 5 cannot access the sub menus. I opend a ticket to support letting them into my dev site and they have confirmed that they see the same issue. The only way I can fix this is to disable the admin bar (the one you showed). Then the problem goes away. Support says this is not the first time that the WordPress admin bar has caused issues.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.