Eleven40 Theme – Problem with Home Featured WIdget after Migration

Community Forums Forums General Discussion Eleven40 Theme – Problem with Home Featured WIdget after Migration

This topic is: resolved

This topic contains 3 replies, has 2 voices, and was last updated by  Anita 1 year, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #50482

    ARogers
    Participant
    Post count: 2

    Hello,

    My site is: MomBizOwners.com and I’m using the Eleven40 theme.

    I am in the process of migrating my hosting to Synthesis. I have not yet changed DNS settings to complete the switch, so the site you see will be with my current host.

    However, after moving the files to the Synthesis site, the Home Featured Widget that I added (while with my old hosting company) no longer works on my Synthesis site when looked at via a proxy server.

    This is the code that I used: http://www.briangardner.com/home-widget-area-eleven40/

    I initially had the Genesis Responsive Slider in the Home Featured Widget with no problems. However it does not show up on my Synthesis site. As a matter of fact, the Home Featured Widget doesn’t show anything. It’s almost as if it’s not even there even though I can see it in the Widgets area.

    Also when I have the home.php in my themes folder, I get the whitescreen – nothing shows up on the front-end. When I delete this file, the site shows up normally minus the Home Featured Widget area.

    Here’s the code that I have in my home.php file:
    —————————————————————————
    <?php
    /** Add the home featured section */
    add_action( ‘genesis_before_loop’, ‘eleven40_home_featured’ );
    function eleven40_home_featured() {

    /** Do nothing on page 2 or greater */
    if ( get_query_var( ‘paged’ ) >= 2 )
    return;

    genesis_widget_area( ‘home-featured’, array(
    ‘before’ => ‘<div class=”home-featured widget-area”>’,
    ) );

    }
    ———————————————————————-

    I originally had this code in the home.php file:

    <?php
    /** Add the home featured section */add_action( ‘genesis_before_loop’, ‘eleven40_home_featured’ );function eleven40_home_featured() { /** Do nothing on page 2 or greater */ if ( get_query_var( ‘paged’ ) >= 2 ) return; genesis_widget_area( ‘home-featured’, array( ‘before’ => ‘<div class=”home-featured widget-area”>’, ) );}
    remove_action( ‘genesis_loop’, ‘genesis_do_loop’ );
    add_action( ‘genesis_loop’, ‘eleven40_grid_loop_helper’ );
    /** Add support for Genesis Grid Loop */
    function eleven40_grid_loop_helper() {

    if ( function_exists( ‘genesis_grid_loop’ ) ) {
    genesis_grid_loop( array(
    ‘features’ => 1,
    ‘feature_image_size’ => 150,
    ‘feature_image_class’ => ‘alignleft post-image’,
    ‘feature_content_limit’ => 750,
    ‘grid_image_size’ => ‘grid-thumbnail’,
    ‘grid_image_class’ => ‘alignnone’,
    ‘grid_content_limit’ => 250,
    ‘more’ => __( ‘[Continue reading]‘, ‘genesis’ ),
    ‘posts_per_page’ => 6,
    ) );
    } else {
    genesis_standard_loop();
    }

    }

    genesis();
    ———————————————————–

    Any ideas of why the Home Featured Widget area shows up on my current host, yet doesn’t show up on the Synthesis site?
    Thank you.

    #50483

    Anita
    Participant
    Post count: 7565

    It should work there also. I would submit a ticket to the support folks at Synthesis.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #50485

    ARogers
    Participant
    Post count: 2

    Okay. Nevermind. As embarrassing as this is to admit, it was a simple solution that I can’t believe I missed.

    I was missing this: genesis();
    at the bottom of the code.

    Matt with CopyBlogger/Synthesis was kind enough to look at this and get it figured out quickly.

    #50487

    Anita
    Participant
    Post count: 7565

    Great, since this is resolved, I will close it.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘Eleven40 Theme – Problem with Home Featured WIdget after Migration’ is closed to new replies.