Embed Videos with Javascript Embed Code into WordPress Post On Genesis Framework

Community Forums Forums Design Tips and Tricks Embed Videos with Javascript Embed Code into WordPress Post On Genesis Framework

This topic is: not resolved

This topic contains 4 replies, has 2 voices, and was last updated by  Summer 4 months, 4 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #75718

    mcuttino
    Participant
    Post count: 3

    I am having issues embedding videos that use javascript code such as the code shown below into a wordpress post on my blog. When I embed videos with code such as this embed code shown below I can’t control the width and height and it ends up bleeding over into my sidebar.

    <script type='text/javascript' src='http://WSET.images.worldnow.com/interface/js/WNVideo.js?rnd=122139;hostDomain=www.wset.com;playerWidth=630;playerHeight=355;isShowIcon=true;clipId=9565394;flvUri=;partnerclipid=;adTag=News;advertisingZone=;enableAds=true;landingPage=;islandingPageoverride=false;playerType=STANDARD_EMBEDDEDscript;controlsType=overlay'></script><a href="http://www.wset.com" title="WSET.com - ABC13">WSET.com - ABC13</a>

    In addition the play button disappers so you can’t play the video and the other functionality incorporated into the video doesn’t work either. I’m using the Genesis Framework and the Streamline Theme. Anyone have any ideas on what I need to do to make this work?

    This is the post where I tried to embed the video: http://blackartblog.blackartdepot.com/black-art-news/danville-museum-honors-camilla-williams.html

    http://blackartblog.blackartdepot.com/black-art-news/danville-museum-honors-camilla-williams.html
    #75738

    Summer
    Participant
    Post count: 756

    Not sure if this applies to your setup or not, but are you pasting the embed code in your post using the Visual editor or the HTML editor?

    I’ve always had to clean up video embeds some of my contributors use when they embed a video while in the Visual editor, and that sometimes corrupts the embed code, partially or fully. Seems to happen all the time with folks who switch an edit session back and forth between both editor modes.

    If you do the embed using the sample theme or one of the default themes, does the same thing happen?


    #75741

    mcuttino
    Participant
    Post count: 3

    I only work in the html view because I do most of my posts in Notepad++ with templates I’ve made for different post types I use and then copy and paste them into wordpress html editor so I don’t think that would be the issue in my case.

    I haven’t tried it in anything other than my streamline studio press theme that runs on the genesis framework. I’ll see what happens if I try to do it on one of the default TwelveEleven or whatever they are calling it now wordpress themes.

    #75742

    mcuttino
    Participant
    Post count: 3

    I even tried adding a <div></div> or <object></object> around that javascript code in an attempt to at least modify the width but that didn’t work at all.

    #75797

    Summer
    Participant
    Post count: 756

    Did you try changing the widths in the javascript?

    Look for playerWidth=630;playerHeight=355; in the embed code, and adjust accordingly, see if that works?

    My guess is they’re using some outdated code tech, and it’s not responsive, and has limited features? Not sure what else to suggest here, since it seems to be something particular to that TV station.


Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.