Enterprise Pro theme – text formatting

Community Forums Forums Design Tips and Tricks Enterprise Pro theme – text formatting

This topic is: resolved

This topic contains 16 replies, has 7 voices, and was last updated by  Gary Jones 5 months, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #88833

    jhguynn
    Participant
    Post count: 216

    I’m using the Enterprise Pro theme and have noticed that when I begin a new sentence after a period, the double space I enter after the period and before the new sentence gets ignored when published and viewed in a browser. It looks like the following:

    “…end of sentence.Then begins a new sentence…”

    WTF? Is there a styling configuration I missed somewhere, because this is unacceptable. Thanks for the help.

    #88835

    efuller
    Participant
    Post count: 44

    Please provide a link for troubleshooting purposes.

    - Eric

    #88837

    jhguynn
    Participant
    Post count: 216

    Sorry. The site is not yet live. Localhost.

    #88840

    efuller
    Participant
    Post count: 44

    How are you entering the text?

    Are you entering it straight from the WP editor? Are you copying and pasting it in?

    #88842

    jhguynn
    Participant
    Post count: 216

    I’m typing it right into the text editor. No copy / paste. No visual editor. I tried wrapping the paragraphs in p tags thinking that might trigger some universal formatting or something, but no change.

    #88850

    eamonmoriarty
    Participant
    Post count: 199

    As far as I know if you use the text editor (as opposed to the visual editor), no matter how many spaces you type in, only one will show up.
    Perhaps this is because most typography experts insist that there should be only one space after a period.
    Have you tried using the visual editor? This will usually insert as many spaces as you want.


    Eamon Moriarty
    EM Dzine

    #88925

    jhguynn
    Participant
    Post count: 216

    Switching to the visual editor did the trick, but what rubbish.

    I never use the visual editor, as I code a lot of things by hand. In fact, I always disable the visual editor. So this means I have to go back through all my pages and posts and re-save them in visual editor mode just to get the text formatted correctly? This sucks.

    Anybody have a solution?

    #89217

    jhguynn
    Participant
    Post count: 216

    Bump.

    I really need to get an answer to this issue. I’m using Enterprise Pro and when I use the text editor, no spaces are retained after the “.” at the end of a sentence and the beginning of the next sentence. I found that if I switch to visual editor and enter text, a single space can be retained, but for lots of reasons I usually deactivate the visual editor and use only the text editor.

    Genesis is such a spectacular vehicle for web design…please tell me I’m not tethered to the visual editor just to enter text the way I’d like.

    I welcome any clarification to help me out of this mess. Thanks.

    #89226

    Ozzy
    Participant
    Post count: 211

    Sorry that you’re having this issue. Do you have a link to the site in question yet?

    If not, is this happening on the home page, single post page or blog page?


    #89244

    Ozzy
    Participant
    Post count: 211

    I don’t think this is a Genesis or Enterprise Pro thing, as it is a WordPress thing.

    http://wordpress.org/support/topic/weird-spacing-between-sentences


    #89245

    jhguynn
    Participant
    Post count: 216

    Ozzy: I think you’re right about it being a WP issue, and not a theme issue. I’m messing around with the plugin raw html to see if that removes the WP idiosyncracies. I’ll report back here if I learn anything.

    PS: I’m developing the site localhost, so I have no link to provide. If the issue persists after I go live, I’ll provide a link then. This formatting problem is happening on static pages and on posts. I don’t use frontpage at all.

    • This reply was modified 5 months, 3 weeks ago by  jhguynn.
    • This reply was modified 5 months, 3 weeks ago by  jhguynn.
    #89247

    chillybin
    Participant
    Post count: 81

    You could always disable autowp using something like

    http://davidwalsh.name/disable-autop

    or use this to toggle it on and off for each post/page

    http://wordpress.org/plugins/toggle-wpautop/


    We are a web design & development consultancy based in Singapore who specialise in all things WordPress & Genesis. | ChillyBin Web Design & Consultancy: http://www.chillybin.com.sg | Twitter: @chillybindesign

    #89249

    Gary Jones
    Moderator
    Post count: 686

    It’s not a WordPress thing. It’s a HTML thing. Whitespace is collapsed (normalized) within textual content, down to a single space. When you use the visual editor, if you check the source, I bet it’s “ “, which is a space, followed by a forced non-breaking space.

    HTML is correct here, and your insistence for double-spacing after full stops is incorrect. It originated from typewriters, which use a monospace font (where the width of a letter i, would be the same as an O for instance). Since your general text (not code snippets) will be using a variable-width / proportional font, the spacing around and particularly after a period is such that the new sentence already stands out.

    The HTML4 spec has some details, though it may also be in earlier specs:

    http://www.w3.org/TR/html4/struct/text.html#h-9.1 – “In particular, user agents should collapse input white space sequences [which includes the space character] when producing output inter-word space.”

    In short, your browser is correcting what you might be able to hack around with the visual editor, but for the sake of consistency, you should only use single spaces after full stops.


    Changes in Genesis 2.1 – the ultimate guide to every single change in Genesis Framework 2.1 and 2.1.1 (all 88 of them!) | @GaryJ

    #89283

    jhguynn
    Participant
    Post count: 216

    Gary Jones, thanks for the detailed response, lot’s of good info there. FYI: I’m not hell bent on getting two spaces after the period of a sentence. Heck I’d settle for just one space. But I’m getting ZERO! Unless I use the visual editor, which allows me one space between sentences, I get nada from using the text editor, no matter how many spaces I type in.

    As I said above, I prefer to disable the visual editor and work in text mode only. I just can’t wrap my head around why it won’t allow even one space after the end of a sentence.

    Chillybin: thanks for the tip re: disabling wpautop. I gave it a shot but it doesn’t seem to have any effect over the “space between sentences” issue. Please elaborate on this if you think I’m missing something.

    The search for a global answer continues, until them I’ll dabble in the visual editor.

    #89286

    Sridhar Katakam
    Participant
    Post count: 923

    That is not supposed to happen and I have never seen it happen in a WordPress site I worked in the last 8 years. I too always use the Text view.

    Can you try deactivating all plugins?


Viewing 15 posts - 1 through 15 (of 17 total)

You must be logged in to reply to this topic.