ERROR: The themes directory is either empty….

Community Forums Forums Design Tips and Tricks ERROR: The themes directory is either empty….

This topic is: not resolved

This topic contains 10 replies, has 4 voices, and was last updated by  WPMuse 1 year ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #64385

    WPMuse
    Participant
    Post count: 8

    Just noticed on this site (http://ParacordPaul.com) that in the dashboard in red is:

    ERROR: The themes directory is either empty or doesn’t exist. Please check your installation.

    The theme is OutReach 2.0. I checked here in the forums and on Google and everything mentioned doesn’t seem to apply to this site.

    The theme is there, the CSS has the theme info at the top — compared with a fresh copy of OutReach’s style.css. The theme’s directory is 755 so I’m not sure what is causing this.

    The theme is displaying properly and the site seems A.O.K… Can someone point me in the right direction? TIA!

    http://ParacordPaul.com
    #64452

    AC
    Blocked
    Post count: 7712

    Can you provide a screenshot of what you are seeing in the dashboard?

    #64460

    WPMuse
    Participant
    Post count: 8

    Hey, Anita:

    Here you go! ;-) Dashboard and top of theme page where you can see Author: “By Anonymous” and no version with the CSS theme info above all in bold.

    Paracord Paul Dashboards

    Thanks for the help!

    #64491

    markmelch
    Participant
    Post count: 37

    The 1st thing I would try is to activate another theme, like Twenty-Thirteen, and then re-activate Outreach.

    #64805

    WPMuse
    Participant
    Post count: 8

    Hey, Mark:

    Activated Twenty-Thirteen. When I did that Outreach was gone and no longer available. Re-uploaded the core theme files via FTP, and then was able to choose the theme and reinstate.

    I am still concerned why this happened. What was the catalyst? Nothing on the site has changed — no new plugins.

    Was it 3.6.1 or a plugin updating to 3.6.1? The fact the same files being re-uploaded to the Outreach directory when deactivated in some way solved this doesn’t make sense. The files uploaded were exact copies of what was there before…

    How can I prevent this from happening again if we don’t know why it happened this time? Thanks! ;)

    #65237

    WPMuse
    Participant
    Post count: 8

    Update…. Logged into the site today and the error is back.

    ERROR: The themes directory is either empty or doesn’t exist. Please check your installation.

    Same as the screenshot previously provided above.

    Apparently this is a technical issue I should submit a support ticket for?

    #65268

    Summer
    Participant
    Post count: 1111

    what does your wp-content/themes folder have in it, as in a complete listing of files and folders? Does anything in there look off? Have you tried doing a security scan on your site, just in case?

    Try using: http://sitecheck.sucuri.net/scanner/


    #65270

    WPMuse
    Participant
    Post count: 8

    Thanks, Summer…

    This site is verified clean and not blacklisted. ;-) The wp-content/themes looks fine too — Genesis, OutReach,
    TwentyThirteen, TwentyTwelve.

    The site is displaying fine…. Just want to determine what this is about — I hate not being able to find a solution.

    #65288

    Summer
    Participant
    Post count: 1111

    I’ve only seen something similar to this twice before. Once, the problem was a physical issue on the server’s hard drive that the ISP’s techs hadn’t discovered yet, and the other time was that files had been uploading via FTP not in binary mode… something that most modern FTP apps have on by default.

    The fact that the theme description is just the first few lines of the CSS file and not the normal display seems to point to a problem in Outreach. Since the other themes display that information correctly, that sort of eliminates an issue with the framework files and the WP core files. Maybe a corrupt include file or something… that’s why I asked about the files. If all the files in themes/outreach are exactly the same as on your computer, and they’re all the same size, I’m not sure what else to check.


    #65351

    WPMuse
    Participant
    Post count: 8

    Hey, Summer:

    Appreciate your input — I agree with your comments. The site is on a VPS and none of the other WordPress sites have this issue so that eliminates the server.

    I also use FTP Voyager all day long on tons of other sites too, set to binary, no issues. I’ve put in a formal support ticket to see if the good folks @StudioPress have any ideas and will report back here for others in the future.

    Thanks again! ;-)

    #65361

    WPMuse
    Participant
    Post count: 8

    Said I would report back.. Here is SP’s response:

    Please check the wordpress.org support forums as I have seen it be an issue with the past couple of versions of WordPress.

    Explained I already did that, it is only this site, and that I work on multiple Genesis/child sites on the same server and many other servers and only this site is behaving in this manner and that I was hoping SP would be open to helping me determine what about this particular site is causing this.

    There’s multiple threads about this over in the WordPress.org forums. It’s also perfectly possible for it to happen on one install on the server and not the rest. It’s not specific to our themes.

    Soooo, if I do figure this out, I will update for others… ;-)

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.