Executive – Posts on Blog Page link to Pages

Community Forums Forums General Discussion Executive – Posts on Blog Page link to Pages

This topic is: not resolved

This topic contains 1 reply, has 1 voice, and was last updated by  Green Being 1 year, 3 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #42939

    Green Being
    Participant
    Post count: 15

    Hi,

    I am using the Executive Theme in the usual way, populating the HOME widgets for creating a “static” home page and then having a Blog page with the blog template selected for displaying featured articles in a separate page.  But when I select the title of the featured post, the link goes to a page with that title versus the post with that title.  If I delete the page with that title, the link goes to the 404 page.  This sounds like a permalink problem, but I am not sure how to get around it.  I set the permalink setting to Post Name, but I think this is working as Page Name.

    Note: I did NOT select the static page option on the Settings > Reading page, since I am using the HOME widgets.

    Thanks for any help.

    http://www.roberthashem.com
    #42955

    Green Being
    Participant
    Post count: 15

    Okay, it was a permalink thing.  I changed the permalink structure …

    FROM:   http://www.example.com/%postname%

    TO:         http://www.example.com/%postname%/%category%

    and it seemed to clear up the issue.

    Still, it would be good to know if this was the correct thing to do in general and why it worked if it was.

    • This reply was modified 1 year, 3 months ago by  Green Being.
    • This reply was modified 1 year, 3 months ago by  Green Being.
Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.