Executive Theme Header Change Dimensions

Community Forums Forums Design Tips and Tricks Executive Theme Header Change Dimensions

This topic is: not resolved

This topic contains 10 replies, has 3 voices, and was last updated by  Mark Scott 1 year, 4 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #14150

    colemanweb
    Participant
    Post count: 13

    Hello,

    I’m trying to enlarge the area allowed for the header image.  Currently it is set to 1140 x 100.  I’d like to allow any height and not have it auto-crop.  Any help would be appreciated.

     

     

    #14157

    braddalton
    Participant
    Post count: 9399

    Change the height values in functions.php (Line 17) and style.css (Line 193).
    [php]
    /** Add support for custom header */
    add_theme_support( ‘genesis-custom-header’, array(
    ‘width’ => 1140,
    ‘height’ => 100
    ) );
    [/php]

    [css]
    #header {
    margin: 0 auto;
    min-height: 100px;
    width: 100%;
    }
    [/css]


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #14163

    colemanweb
    Participant
    Post count: 13

    Thank you Brad, worked like a dream.  Is there any way to let it not crop?  If I have images that are too short, it blows them up and then crops.  Some are give or take 30 pixels either direction.

    #14171

    braddalton
    Participant
    Post count: 9399

    You might want to layer them on a background using a tool like Paint.net or GIMP if you don’t use Photoshop.

    If they’re the exact same size as your settings, they should be displayed as is.


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #35915

    Mark Scott
    Participant
    Post count: 10

    Brad, I’m having the same problem.

    I have the settings in my CSS and functions.php, exactly as you’ve shown them. My header image is exactly 1140 X 100.  I can see it in the media library, but it won’t display on the pages.

    If I use a smaller-sized image (all I really want is a logo 172 x 50) it gets blown up to an enormous size and I’m forced to crop it. What happended to the skip cropping option?

    Any help will be most appreciated.

    The site is http://www.innov8.net.au

    Header text is still showing, but a header image is set.

    #35919

    braddalton
    Participant
    Post count: 9399

    I just layed a logo 172 x 50 on 1140 X 100 background using Paint.net and it worked perfectly.

    Use a white or transparent background.


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #35920

    Mark Scott
    Participant
    Post count: 10

    Brad, thanks for the quick response!

    I am using a transparent background.

    Here is the image: http://web.innov8.net.au:8080/wp-content/uploads/2013/04/header-logo.png

    Oh, I just tried displaying it in a browser and I get an internal server error. It looks like this might be an IIS issue.

    #36009

    braddalton
    Participant
    Post count: 9399

    It should work. Check your settings under Appearance > Header and if the dimensions match your image, upload it.


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #36014

    Mark Scott
    Participant
    Post count: 10

    It’s working now. It was a file permission error.

    Thanks for your time, Brad.

    #36019

    braddalton
    Participant
    Post count: 9399

    Good stuff. Who are you hosting with Mark?


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #36033

    Mark Scott
    Participant
    Post count: 10

    Paul, the website is a friend’s. He self-hosts and is in the process of configuring a new build.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.