Family Tree, Regular Blog Page for front page?

Community Forums Forums General Discussion Family Tree, Regular Blog Page for front page?

This topic is: not resolved

Tagged: 

This topic contains 6 replies, has 2 voices, and was last updated by  lalagirl 1 year, 6 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #18102

    lalagirl
    Participant
    Post count: 3

    Wondering if someone can give me some direction for my Family Tree themed site?

    Basically, I want the front page of my site to look like a traditional blog, with posts on it – in order to do that, I understand that I have to delete/rename the home.php file included with the theme. I did that. But now the date stuff lines up all wonky.

    Main page, and how it looks now: http://housewifehellraiser.com/

    How I WANT it to look: http://housewifehellraiser.com/blog/

    See the difference? I found a post on the old StudioPress support forum that addresses the exact issue, but it’s written more for people who know what they’re doing with PHP, i.e., NOT ME. Here is what it says to do:

    “You’ll also need to make edits to the functions.php and style.css files in order to get the date flags to work correctly.

    Here are the steps I took to set up a blog-style homepage on my staging site:

    1. Set my default layout to Content-Sidebar in Genesis Settings
    2. Renamed home.php to not-home.php.
    3. Deselected “Show Featured Image” under Genesis Excerpt settings, changed from excerpt to full content with no character limit and saved my changes.
    4. Added an is_home() conditional to the post-date function in functions.php – the widgeted home page doesn’t use date flags, so you need to include them in the if statement.
    5. Deleted the .home .post-info .post-edit-link CSS for the same reason.”

    I tried to figure out how to add the is_home() conditional but I jacked up the whole thing. Can someone just tell me what I need to add? Like, here, Laura, copy and paste THIS. I really appreciate any help. Thank you!

    #18304

    Kraft
    Participant
    Post count: 86

    I *think* this will do it for you…

    (you may have already done the first part of this…)
    1. Create a new page for your site. Title it whatever you want (Home), etc. Content doesn’t matter.
    2. On the right-hand side, under the publish button, look for Page Attributes.
    3. Change Template from Default Template to Blog
    4. Save.

    (this is what is new, I think).
    5. Go to Settings->Reading from the left-side nav in wp-admin
    6. Change Front Page displays from “your latest posts” (which home.php uses) to A static page
    7. Choose the new page you made (or your existing blog page).
    8. Save


    Brandon Kraft
    Volunteer
    Blog | Twitter | Business
    Genesis eNews Extended Support

    #18325

    lalagirl
    Participant
    Post count: 3

    Thanks for your reply, Brandon. Yep, I’ve tried that – (I linked the blog page in my original post above) – unfortunately when I do it like that, the “older posts” link at the bottom doesn’t work. Soooo…I guess I could figure out a way to fix the “older posts” link – that might be easier?

    The older posts link just keeps showing one page of posts.

    #18329

    Kraft
    Participant
    Post count: 86

    Hmm.. Testing it out, it seems to be an issue on any theme if you set it up like that. So, let’s punt to a different suggestion and ignore that issue.

    In your functions.php file, look for the line that starts with
    add_action( ‘template_redirect’, ‘familytree_conditional_actions’ );
    Replace that line and the lines that follow (up to, but including the random-looking } with the this code.

    If you compare the original with what I linked, all we are doing is adding “|| is_home()”, which is telling WP to apply the fancy dates to the home page as well.

    The Settings->Reading should be set to “your latest posts”.


    Brandon Kraft
    Volunteer
    Blog | Twitter | Business
    Genesis eNews Extended Support

    #18703

    lalagirl
    Participant
    Post count: 3

    Yay! That worked for the fancy dates!

    The post title is still a little wonky, all in caps – and there’s a weird dotted line thing between the comment number and the content – hmmm.

     

    Thanks so much for your help, Brandon – truly appreciate it!

    #18705

    Kraft
    Participant
    Post count: 86

    I’m not seeing the dotted line (at the moment), but assuming you’re not an all-caps kind of gal, you can remove the text-transform: uppercase; line near line 1567 of style.css.

    That would normal-case all H2′s on your site. If you want H2′s upper, just not the home titles, we can get a little more specific.


    Brandon Kraft
    Volunteer
    Blog | Twitter | Business
    Genesis eNews Extended Support

    #18706

    lalagirl
    Participant
    Post count: 3

    Huh – I think the dotted line is there for me because I’m logged into WordPress.

    I’ll dig into the text-transform thing. Again – many thanks for your help, Brandon! You’re a BAMF! :-)

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.