Favicon not showing in all browsers

Community Forums Forums General Discussion Favicon not showing in all browsers

This topic is: not resolved

Tagged: 

This topic contains 10 replies, has 3 voices, and was last updated by  giddymoon 6 months, 2 weeks ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #104086

    giddymoon
    Participant
    Post count: 13

    Hi,

    I am using Agency child theme 2.0. I’ve placed my new favicon in the root directory, in the Genesis theme images file and in the Agency image file. I’ve cleared the cache on the site and browsers. I’ve followed all instructions provided in other threads: Genesis favicon uploader plugin, add the code snippet to the functions.php file. And still, the favicon shows only in my Firefox browser, but not in Chrome or Safari.

    Also, when I try to access the favicon directly here:

    http://www.curtisfinancialplanning.com/wp-content/themes/agency/images/favicon.ico

    I get a 404 error.

    When I check the site with

    http://validator.w3.org/checklink

    I get a 403 message:

    Line: 66 http://www.curtisfinancialplanning.com/wp-content/themes/agency/images/favicon.ico
    Status: 403 Forbidden

    The link is forbidden! This needs fixing. Usual suspects: a missing index.html or Overview.html, or a missing ACL.

    Can anyone suggest what I should check next?

    Thanks!
    Linda

    http://www.curtisfinancialplanning.com
    #104103

    neilgee
    Member
    Post count: 131

    I can see a 404 error on the favicon path – maybe a permissions issue on the images folder
    /wp-content/themes/agency/images/

    Should be 775


    Neil Gee
    Coolest Guides

    #104118

    giddymoon
    Participant
    Post count: 13

    Hi Neil,

    Thanks for getting back to me!

    The permissions on the images file is 755. I thought that was okay??? I tried changing it to 775 and still no favicon.

    Linda

    #104121

    neilgee
    Member
    Post count: 131

    If you put a bonafide image .jpg in the images folder can you see the image via a browser…

    http://www.curtisfinancialplanning.com/wp-content/themes/agency/images/randonimage.jpg

    If you cant, it has to be a permission thing, if you can it may be site block on .ico files – perhaps via .htaccess


    Neil Gee
    Coolest Guides

    #104162

    giddymoon
    Participant
    Post count: 13

    Thanks very much Neil.

    I’ll try it out this morning.

    I appreciate your help.

    #104164

    giddymoon
    Participant
    Post count: 13

    Hi again,

    The image in the file displays. So perhaps the .ico file is blocked via htaccess.

    How can I tell?

    I looked at the .htaccess file and the RewriteEngine is enabled and these are the first two lines after:

    ## Disallow access to htaccess.txt, configuration.php, configuration.php-dist and php.ini
    RewriteRule ^(htaccess\.txt|configuration\.php(-dist)?|php\.ini)$ – [F]

    Thanks,
    Linda

    #104202

    neilgee
    Member
    Post count: 131

    Hi Linda – not really knowing your hosting environment I don’t want to randomly do a copy/paste in htaccess, the fact that you can see a non .ico image says to me that the .ico type is blocked – you’ll have to raise a support ticket with them or even try just changing the favicon extension to .png – that may work


    Neil Gee
    Coolest Guides

    #104206

    giddymoon
    Participant
    Post count: 13

    Hi Neil,
    I’ll take your advice and submit a support ticket with my host…after I try changing the favicon extension.

    You have been very helpful.

    Thanks so much,
    Linda

    #104208

    giddymoon
    Participant
    Post count: 13

    Changing the extension worked!

    you rock!
    Linda

    #104209

    essaysnark
    Participant
    Post count: 342

    Is the image in your favicon a black silhouette on a yellowish background? Because I’m seeing it show up in both Firefox and Chrome.

    #104312

    giddymoon
    Participant
    Post count: 13

    Hi,

    Thanks for getting back to me. On the suggestion of Neilgee I changed the extension on the favicon file from ico to png and it worked!

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.