focus css question

Community Forums Forums Design Tips and Tricks focus css question

This topic is: resolved

This topic contains 11 replies, has 2 voices, and was last updated by  Tony @ AlphaBlossom 1 year, 10 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #18483

    2TechGirls
    Participant
    Post count: 12

    I’m using the focus child theme and would like to change the css for the blog display page. If you look at the theme demo page – http://demo.studiopress.com/focus/  the first two blog posts are full width to the sidebar. The posts after that are in a two column format. I would like to remove that and have all the posts display the same as the first two.

    Where can I edit the css to do that?

    Thanks.

    Kris

    #18486

    Tony @ AlphaBlossom
    Participant
    Post count: 544

    If you want to change it using just css (keeping the rest of the format the same), you can add:


    .home .genesis-grid-even,
    .home .genesis-grid-odd {
    width: 100%;
    }

    Adding .home will only change it on the homepage, that way you don’t change this layout on other pages.

    Tony
    AlphaBlossom


    #18497

    2TechGirls
    Participant
    Post count: 12

    Hi Tony,

    Thanks, that did work. Now I have to set things so the post image displays before the Read More link. Do you know how I can change that?

    Kris

    #18499

    Tony @ AlphaBlossom
    Participant
    Post count: 544

    Hi Kris,

    Glad that helped. I’m not following you on the post image. When I look at the demo page, the “continue reading” link is the last thing to display for each post.

    Tony


    #18500

    2TechGirls
    Participant
    Post count: 12

    Ok, I did make the new theme live since this is the last of the customizations – http://www.chicityfashion.com/

    I need to have at least one image displaying before the “read more” link

    Thanks.

    #18509

    2TechGirls
    Participant
    Post count: 12

    New problem – the side widgets are not displaying at all. Also, part of the footer – the copyright – is displaying below the header of the site. I’ve made sure the original functions.php page is there, with no customizations.

    How can i get the sidebar to display and the footer to display correctly?

    #18513

    Tony @ AlphaBlossom
    Participant
    Post count: 544

    I wasn’t sure if you just wanted the lower posts wider, or if you wanted them the same as the first couple of posts. If you open your home.php (child theme folder), you’ll see this code:


    genesis_grid_loop( array(
    'features' => 2,
    'feature_image_size' => 0,
    'feature_content_limit' => 0,
    'grid_image_size' => 'grid-thumbnail',
    'grid_image_class' => 'alignnone',
    'grid_content_limit' => 250,
    'more' => __( '[Continue reading]', 'genesis' ),
    'posts_per_page' => 6,
    ) );

    If you change ‘features’ you can display more posts like the first two. You might also want to change ‘posts_per_page’ if you want to show more than six post.

    If you do this, you can reset the css above since you won’t be showing the grid posts on the home page.

    Your sidebar is there, but it’s empty.

    The copyright text looks like it’s in your header widget, so you’ll have to go into your admin panel and remove that.


    #18514

    Tony @ AlphaBlossom
    Participant
    Post count: 544

    Actually, just looked at it and it looks like you got it all sorted out now :)


    #18548

    2TechGirls
    Participant
    Post count: 12

    Actually, I was able to fix most of this, but there is still one problem.

    On each separate post page, the sidebar is displaying on the side where it should, but also below the post. How can I get rid of the duplication?

    Here’s an example – http://www.chicityfashion.com/fashion-week-essentials/

    Thanks.

     

    #18584

    Tony @ AlphaBlossom
    Participant
    Post count: 544

    It looks like you have a separate widget (class of .after-post) area that’s duplicating the sidebar widget. You should check in your admin widget area to see if it’s duplicated there. If not, maybe in your functions.php.


    #18676

    2TechGirls
    Participant
    Post count: 12

    Tony, thanks for your help. When I changed the theme, the widgets were either moved or duplicated for some odd reason. I cleaned that up and everything is displaying properly.

    #18712

    Tony @ AlphaBlossom
    Participant
    Post count: 544

    Awesome, glad you got it all sorted out! Have a great day :)


Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘focus css question’ is closed to new replies.