FSCF Enterprise Theme FireFox Issue

Community Forums Forums Design Tips and Tricks FSCF Enterprise Theme FireFox Issue

This topic is: not resolved

This topic contains 1 reply, has 2 voices, and was last updated by  David Chu 1 year, 7 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #99716



    I’m using the fast secure contact form plugin and for some reason the form works perfectly well in Chrome, in IE the letters are pushed to the bottom of the field, but in FireFox you cannot see the text being typed into the fields.


    I am currently using this form on multiple other sites and am not running into the issue which leads me to believe it has to do with the styling elements of Executive Pro.

    Any help is greatly appreciated!


    David Chu

    Interesting question. That plugin has programmer-itis, in that the coder sticks inline CSS on every little part, trying to regulate everything the old-school pre-CSS way. As a CSS person, I don’t care for that, and quit using that plugin finally.

    Anyway, I believe this is one of those cases where Firefox is being more literal than other browsers, it’s just “following orders”, and the others are not strict, and they auto-fix it for you. Essentially, you have a height of 35px on an INPUT field, and elsewhere the styling is saying “use 1.6 rem of padding”. In this context, that leads almost to zero, thus squishing the text.

    So maybe on your form settings you can use a taller height, OR you can play with the padding and/or font sizes on the CSS below:
    (Appearance…. Edit, etc.)

    input, select, textarea {
      background-color: #F5F5F5;
      border: 1px solid #DDDDDD;
      box-shadow: 1px 1px 3px #EEEEEE inset;
      color: #222222;
      font-family: ‘Open Sans’,’Helvetica Neue’,Helvetica,Arial,sans-serif;
      font-size: 1.4rem;
      padding: 1.6rem;
      width: 100%;

    Cheers, Dave

    Dave Chu ยท Custom WordPress Developer – likes collaborating with Designers

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.