Generate Box is not displaying in Generate

Community Forums Forums General Discussion Generate Box is not displaying in Generate

This topic is: not resolved

This topic contains 39 replies, has 4 voices, and was last updated by  tproud 1 year, 1 month ago.

Viewing 15 posts - 1 through 15 (of 40 total)
  • Author
    Posts
  • #51725

    webmaster@uthsc.edu
    Participant
    Post count: 13

    I have just activated Generate and, in my widgets area, there is an option to add widgets to “Generate box” but it does not display anywhere and I can’t find any options to make it appear. Does anyone know what I need to do to make it work.

    #51729

    Anita
    Participant
    Post count: 7565

    Did you follow these instructions?

    http://my.studiopress.com/setup/generate-theme/


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #51735

    webmaster@uthsc.edu
    Participant
    Post count: 13

    Yeah, but as with most Genesis documentation, it’s vague and uninformative; it doesn’t really provide any information about how to actually make it display. My problem is that, even when I drag widgets to the generate box on the widgets screen, it doesn’t appear anywhere on my site.

    #51736

    Anita
    Participant
    Post count: 7565

    Please provide a link to your website so I can take a look at what you have.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #51738

    webmaster@uthsc.edu
    Participant
    Post count: 13

    Ok, so I’ve discovered that the “Generate Box” requires a plugin. Even though it appears in the widgets area in the admin panel, it will not appear on the site until the plugin is installed. Now that I have the plugin installed, it appears on the homepage but it isn’t widgetizable. even if I add widgets to it, it just stays black. So far, I haven’t had much luck finding any useful documentation about it.

    #51740

    Anita
    Participant
    Post count: 7565

    It’s difficult to troubleshoot when I cannot actually see it. If you want, use the contact box on my website and send me a message along with the URL so I can see it.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #51744

    webmaster@uthsc.edu
    Participant
    Post count: 13

    Thanks, but unfortunately the site is on a private development server and I am unable to share it. Is there something I need to do to be able add widgets to the generate box? Why does it appear in the widgets area if you have to install a plugin? and why does adding widgets to it seem to have no effect? I feel like these are reasonable questions that should be included in the generate box documentation.

    #51747

    Anita
    Participant
    Post count: 7565

    Like I said, I cannot troubleshoot in the blind. The theme works. I have it on two clients at the moment. Other than the documentation provided by Studiopress, there isn’t anything else. If you feel it’s a technical issue, fill out a support ticket with Support under my.studiopress.com.


    When asking for help, please provide a link or screen shot showing your problem!
    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me!

    #52630

    tproud
    Participant
    Post count: 37

    Hi. I have the same problem, my generate box won’t show up on the site although it appears in the widgets area in the admin panel. I have read the documentation but it was not helpful, unfortunately. What plugin do I need to use for it to show up? My site is at http://lendingbeeinc.com/test/. Thank you!

    #52640

    tproud
    Participant
    Post count: 37

    OK, I have installed and activated the Generate Box plugin and it appears on my front page but is completely blank, even though there are 3 widgets in it. How do I get them to show up in the generate box at http://lendingbeeinc.com/test/? Please help, thanks.

    #52641

    webmaster@uthsc.edu
    Participant
    Post count: 13

    Well, it looks like you’ve successfully added it but here’s what I’ve got so far.

    By default, it seems that the Generate Box only appears on the feed pages; not static pages – even if you have one set as your home page. Of course you have to add widgets to it in the Widgets area before it shows up.
    You can download the generate box plugin to add some options but it doesn’t provide an option to add it to any page.
    If you do want to display the generate box to a static page, your best bet is probably going to be look up the generate box function and hook it in to your theme in your functions.php file or a custom template file.
    Depending on whether or not I end up using it, I’ll try to make sure to add the code I use here (Since the complete lack of documentation on the generate box isn’t going to help anyone very much.)

    #52643

    tproud
    Participant
    Post count: 37

    Thanks for your response. Yes, I have added widgets to the generate box but as you see it appears blank. So if I use a static page as my front page, I won’t be able to use the generate box? That’s disappointing. Anyway, I actually need it to have a slider on my front page and i cannot find a way to do it. Thought using the generate box would help, but….

    #52644

    webmaster@uthsc.edu
    Participant
    Post count: 13

    @tproud, it may be that installing the generate box plugin screws up the widget functionality. I haven’t really gone in and looked at the code yet but, considering how simple it should be, I’m surprised at how janky and it is. The official website for the plugin (http://generatebox.com/) provides absolutely no documentation or even general information which is a pretty good indication that we should probably avoid it all together. It would be nice to get some feedback from the developers.

    #52648

    tproud
    Participant
    Post count: 37

    Looks like you are right. However the Generate theme is all about this box and without the plugin it does not even show up. However maybe the problem is using the static page as a front page. Not very flexible.

    Still I’m hoping @anitac might help.

    #52649

    mokito
    Participant
    Post count: 2

    tproud, You’ll need to update the generatebox settings under the theme you’re using’s tab, not in the widgets area. Screenshot: http://oi42.tinypic.com/i38kt1.jpg

Viewing 15 posts - 1 through 15 (of 40 total)

You must be logged in to reply to this topic.