Generate Theme Help!

Community Forums Forums Design Tips and Tricks Generate Theme Help!

This topic is: not resolved

This topic contains 7 replies, has 3 voices, and was last updated by  wptheme 1 year, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #11878

    pensfan6636
    Participant
    Post count: 4

    Hello,

    I purchased the Generate theme, have it installed and have already done some modifications to it.

    What I am having trouble with is how my post are showing up on the home page.

    Here is my site http://www.brandenpierce.com

    It is showing the first 2 as full post. I want the post too look exactly as it does in the demo: http://demo.studiopress.com/generate/

    I want them as excerpts like that. Preferably automatically (dont want to have to inert a “Read More” short code each time)

    How can I get this achieved?

    The one thing different I want is to have the featured Image in the past as well.

    Thanks in advance for your help!

    -Branden

    #12041

    pensfan6636
    Participant
    Post count: 4

    Anyone able to help?

    #12052

    Jon Bellah
    Participant
    Post count: 109

    You’re adding the image to the post itself, rather than using the “Featured Image” uploader. It should be on the right-hand side of your WordPress post dashboard. Upload your image there and set it as your featured image. WordPress/Genesis will take care of the rest.

    As for how to display post excerpts, rather than full content. From your WordPress dashboard, go to: Genesis -> Theme Settings, scroll down to the “Content Archives” section. In the dropdown, select Display post excerpt.

    That should do it.


    Follow me on the Twitters at @JonBellah. I blog about web design, development and a lot about Genesis at CSSForge.com

    #12063

    pensfan6636
    Participant
    Post count: 4

    Okay, as far as the featured image I was using the featured image uploader, I just didnt have the correct sizes. As you can see now, this corrected for the regular size post (not grid).

    As for the grid, if I add a 290×130 featured image, it looks correct on the home page, but obvioulsy is still 290×130 on the blog post.  Is there a way to set it as the 610×170, but to auto shrink to 290×130 on the home page?

    As far as the post excerpts. I has the option set in genesis setting and still not working. Also tried changing it to display post content and limit it to “x” number of characters and this did not work either.

    I dont know if something is overriding these options somehow?

    Thanks for your response btw

     

    #12064

    pensfan6636
    Participant
    Post count: 4

    FYI, as far as the shrinking the image for grid post, this isnt super importnt. I can live with how it is.

    I just really want to get this post excerpt issue resolved.

     

    Thanks

    #12264

    Jon Bellah
    Participant
    Post count: 109

    Go back to Genesis -> Theme Settings, scroll down to the Content Archives section. In the dropdown, select Display Post Content, then below that, in the box labeled “Limit post to”, insert the number of characters you want to limit your excerpt to.


    Follow me on the Twitters at @JonBellah. I blog about web design, development and a lot about Genesis at CSSForge.com

    #12324

    pensfan6636
    Participant
    Post count: 4

    I mentioned that I already tried that and it still did not work. I tried setting the drop down to post excerpts and Display Post Content with a character limit. And it still shows the full content for the first 2 post.

    Now…. I did a little rummaging in the code and found this:

    /** Add support for Genesis Grid Loop **/
    function child_grid_loop_helper() {

    if ( function_exists( ‘genesis_grid_loop’ ) ) {
    remove_action( ‘genesis_before_post_content’, ‘generate_post_image’, 5 );
    genesis_grid_loop( array(
    ‘features’ => 2,
    ‘feature_image_size’ => ‘featured’,
    ‘feature_image_class’ => ‘alignleft post-image’,
    ‘feature_content_limit’ => 0,
    ‘grid_image_size’ => ‘grid’,
    ‘grid_image_class’ => ‘alignleft post-image’,
    ‘grid_content_limit’ => 0,
    ‘more’ => __( ‘Continue reading…’, ‘genesis’ ),
    ‘posts_per_page’ => 6,
    ) );

    If I change the “feature_content_limit” line to say 200.  The changes take affect on the home page.

    The problem though is that I would like to keep the formatting of the post the same. I would like excerpts but the format to still show in that excerpt. When I change that line of code, it removes formatting for the excerpt on the home page.

    You can see in the Generate theme demo, the formatting is still there in the excerpts on the home page (the bold letters)

    Also, I would like to just have the setting work in theme settings. Strange that it isnt.

     

    Thanks for your continued help :)

    #15591

    wptheme
    Participant
    Post count: 1
    This reply has been marked as private.
Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.