Generate Theme – Weird Image Alignment?

Community Forums Forums Design Tips and Tricks Generate Theme – Weird Image Alignment?

This topic is: not resolved

Tagged: 

This topic contains 3 replies, has 3 voices, and was last updated by  aweinclusive 1 year, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1859

    larkrise
    Participant

    Hi there

    I cannot work out why on the Home page the image is doing something completely weird and unseen?

    http://leahreviews.com/

    The actual post is http://leahreviews.com/internet-marketing-how-do-you-know-whom-to-trust/ and on the post it looks fine.

    On the homepage it’s been scewed and doubled, one image is aligned to the sidebar?

    Completely lost on the cause of that so feedback is greatly appreciated

    Thanks, Leah

    #1867

    SoZo
    Moderator
    Post count: 1573

    The grid loop is set to pull in the post thumbnail. That is the first image you are seeing. Then since you’ve inserted the image into the post content and the grid loop is set to pull in the full content you are getting the image again. To remove the thumbnail open up home.php and change
    'feature_image_size' => 'featured',
    to
    'feature_image_size' => 0,

    And please, in the future, insert the name of the theme you are using in the Tags field.


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

    #2009

    larkrise
    Participant

    Whoops – I broke it – sorry Sozo, literally copied the above and pasted over similar text – not sure what I did wrong?

    I tried to put it back but that didn’t work
    if ( function_exists( ‘genesis_grid_loop’ ) ) {
    remove_action( ‘genesis_before_post_content’, ‘generate_post_image’, 5 );
    genesis_grid_loop( array(
    ‘features’ => 2,
    ‘feature_image_size’ => ‘featured’,
    ‘feature_image_class’ => ‘alignleft post-image’,
    ‘feature_content_limit’ => 0,
    ‘grid_image_size’ => ‘grid’,
    ‘grid_image_class’ => ‘alignleft post-image’,
    ‘grid_content_limit’ => 0,
    ‘more’ => __( ‘Continue reading…’, ‘genesis’ ),
    ‘posts_per_page’ => 6,

     

    Getting this error

    Parse error: syntax error, unexpected ‘=’, expecting ‘)’ in /home/leahrevi/public_html/wp-content/themes/generate/home.php on line 24

    #11307

    aweinclusive
    Participant
    Post count: 1

    That worked to fix my problem!  Thank goodness!  One of my goals this year is to fire myself because I don’t know what the hell I’m doing.  Need to start researching a real designer and stop spending so much valuable time doing it myself!

    All of that to say, THANK YOU SoZo!

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.