Genesis 2.1 not playing nice with bbPress.

Community Forums Forums Design Tips and Tricks Genesis 2.1 not playing nice with bbPress.

This topic is: not resolved

This topic contains 10 replies, has 2 voices, and was last updated by  jonbarratt 4 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #112147

    jonbarratt
    Member
    Post count: 17

    Hi Guys

    Nice work on 2.1 and the new additions. As you say, it was already extremely stable.

    I guess there are always going to be some teething problems with a new release. I upgraded to 2.1 and my entire bbPress forum went down. Any forum page is simply blank. Anyone else having the same problem? I’ve since gone back to the previous version. Any ideas?

    Cheers
    Jon


    http://www.jonbarratt.com | Facebook
    “I don’t have any idea what I’m doing half the time. The other half, I’m brilliant. Asleep, but brilliant.”

    http://envy.krolyn.com
    #112190

    Pavle
    Member
    Post count: 134

    Hi Jon,

    I have exactly the same problem. Its definitely something on the Genesis 2.1 side.
    Lets hope they will solve it, my forum is showing internal server error.

    #112213

    jonbarratt
    Member
    Post count: 17

    I think I’ve narrowed it down to the bbPress Genesis Extend plugin rather than the bbPress plugin. I’m just trying to identify the problem area. Perhaps, this will at least help to get your forum back online Pavle.


    http://www.jonbarratt.com | Facebook
    “I don’t have any idea what I’m doing half the time. The other half, I’m brilliant. Asleep, but brilliant.”

    #112224

    Pavle
    Member
    Post count: 134

    John,

    Here is what guys from support told me. Unfortunately its not working for me, but perhaps it might work for you
    ” Please go to Settings -Permalinks and resave. No need to change, just save.”

    Let me know. I will post here if I find a solution in the meanwhile.

    #112235

    jonbarratt
    Member
    Post count: 17

    No success.


    http://www.jonbarratt.com | Facebook
    “I don’t have any idea what I’m doing half the time. The other half, I’m brilliant. Asleep, but brilliant.”

    #112243

    jonbarratt
    Member
    Post count: 17

    I have narrowed it down to this piece of code on line 254 of the bbpress-genesis-extend.php in the bbPress Genesis Extend plugin.

    $retval = genesis_get_option( ‘site_layout’, null, false );

    If you remove it, the bbPress forum pages are reinstated. I’ve looked through the Genesis Change Log but can’t find the reason why this line of code would present a problem. Perhaps support could weigh in.

    Best
    Jon


    http://www.jonbarratt.com | Facebook
    “I don’t have any idea what I’m doing half the time. The other half, I’m brilliant. Asleep, but brilliant.”

    #112326

    Pavle
    Member
    Post count: 134

    Jon,

    I would have never figured out that myself. Thanks.
    So upon your advice I removed this

    // Set some defaults
    $forum_id = bbp_get_forum_id();
    // For some reason, if we use the cached version, weird things seem to happen.
    // This needs more investigation, for now we pass false as a work around.
    $retval = genesis_get_option( ‘site_layout’, null, false );
    $parent = false;

    What worries me is that it says

    For some reason, if we use the cached version, weird things seem to happen.

    I am using W3 cache, so lets hope there will be no problems. Perhaps this can be further investigated by the support team.

    #112327

    jonbarratt
    Member
    Post count: 17

    Hi Pavle

    Yes, I agree. It’s worth finding out WHY that variable code is causing trouble with the new Genesis version. I’ve put in support tickets to both StudioPress and also to the author of the plugin. As soon as I get a response, I’ll update the forum.

    In the meantime, I have opted to restore the previous Genesis version rather than omit the passage of code.

    Best always
    Jon


    http://www.jonbarratt.com | Facebook
    “I don’t have any idea what I’m doing half the time. The other half, I’m brilliant. Asleep, but brilliant.”

    #112512

    jonbarratt
    Member
    Post count: 17

    Hi Pavle

    2 solutions have now been offered – one from the plugin developer, Jared Atchison – the other from the plugin’s distributor, Travis Smith – https://github.com/jaredatch/bbPress-Genesis-Extend/issues/4

    Jared’s solution – https://github.com/jaredatch/bbPress-Genesis-Extend/commit/f1af57f16adf405ef25b1a4f3b554cf714508943
    Travis’s solution – https://github.com/wpsmith/bbPress-Genesis-Extend/commit/049f982381f22eac7c21a99d8c0cd16399a244a0

    I would assume we’ll see an update to the plugin appearing soon (inclusive of Jared’s changes).

    Best always
    Jon


    http://www.jonbarratt.com | Facebook
    “I don’t have any idea what I’m doing half the time. The other half, I’m brilliant. Asleep, but brilliant.”

    #112518

    Pavle
    Member
    Post count: 134

    Hi Jon,

    Many thanks for posting an update here.
    Few hours ago plugin has been updated at least on my site.
    I am sure you will see it soon.

    It works for me right now (I assume the line I deleted previously got deleted).

    Well, now I have to work on styling my forum a bit.

    Best wishes.
    Pavle

    #112519

    jonbarratt
    Member
    Post count: 17

    All good, Pavle. Works fine here too. Best, Jon


    http://www.jonbarratt.com | Facebook
    “I don’t have any idea what I’m doing half the time. The other half, I’m brilliant. Asleep, but brilliant.”

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.