Get 404 error page when adding/updating post

Community Forums Forums General Discussion Get 404 error page when adding/updating post

This topic is: not resolved

This topic contains 3 replies, has 3 voices, and was last updated by  Herman 1 year, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #44868

    Herman
    Participant
    Post count: 90

    This doesn’t happen every time I add a new post or update an old one but it’s occurring with increasing frequency on my blog at: http://www.drostdesigns.com particularly when I write a long post.  I tried from another computer, logging off and on but to no avail.

    What’s your recommendation for resolving this problem?

    Thank you.

     

     

     

     

     

    http://www.drostdesigns.com
    #44873

    Anita
    Blocked
    Post count: 7712

    If you add a post and then you edit the permalinks this will happen. Let’s say you viewed a page when you first save it. And you have it open in another tab. You go back, modify the text and then modify the permalink. You open the site in that other tab and refresh your screen – it will give you a 404 because you changed the permalink.

    #44908

    Bill Murray
    Participant
    Post count: 575

    @Herman – If you are on a webserver that runs Apache, I think your problem is related to mod_security, which is an Apache security module. It’s a common problem with WP running on Apache servers, and it can trigger some bizarre outcomes, such as not being able to save a post because it contains a single, specific word. Here’s an example.

    I recommend you check with your webhost and see if you’re running mod_security. If you are, ask your webhost to examine the mod_security logs. In most installations, these are in /var/log/apache2/mod_security on the server. If you got a 404 as a result of a mod_security block and logging was enabled, you should see a log entry that explains that. If you find that is the source of the problem, you’ll have to work with your web host to adjust mod_security rules so as not to block the activity that was blocked. It’s generally not a good idea to turn off mod_security altogether.

    Hope that helps.


    Web: https://wpperform.com or Twitter: @wpperform

    We do managed WordPress hosting.

    #44993

    Herman
    Participant
    Post count: 90

    Thanks Anitac..good to know
    Bill..I’ll check with my host

    I temporarily solved the problem by deactivating all my plugins.

     

     

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.