Header logo not responsive. Can it be?

Community Forums Forums Design Tips and Tricks Header logo not responsive. Can it be?

This topic is: resolved

This topic contains 7 replies, has 3 voices, and was last updated by  dev 1 year, 5 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #38240

    dev
    Participant
    Post count: 457

    We moved from another vendor to SP… for us and our clients so we are new to the platform.

    Using the Optimal theme on this site. Everything is responsive except the header-logo. It’s  a typical background image. The generated CSS is:

    #header {
    background: url(http://newmediawebsitedesign.com/wp2/wp-content/uploads/logo4.19-B.png) no-repeat;
    }

    Is there any way to make the logo responsive? It can be done with Catalyst by inserting the image into a hook via code. Is there a way to do it with Genesis?

    Thanks.

     

    http://www.newmediawebsitedesign.com
    #38249

    braddalton
    Participant
    Post count: 10217
    #38334

    dev
    Participant
    Post count: 457

    Thank you. I put my already uploaded logo from Media Lib into this plugin (in the 769xlogo spot) and now it is responsive. I don’t know what the other sections are for but it worked great on my iPhone. This is the link.

    Again, thank you for posting this. You did a good service. Those of us who are new to this platform value your many contributions… just so you know that.

    #38340

    dev
    Participant
    Post count: 457

    Maybe I spoke too soon. The plugin worked fine for a site with the Optimal theme but I can’t get it to work with a site with the Legacy theme. When I try to “upload” a .png file from the Media Library… nothing shows up in the text box… it is as if nothing happened. I even tried to upload a .jpg from my local machine… and nothing. Makes no sense to me. I checked permissions, etc.  (I set the plugin files and dirs to 777 to test.) No errors are thrown… it just looks as if nothing happens. If a file is already in Media Lib, why does the plugin not “register” it?

    I left a post on Nick’s site so maybe he can figure it out.

    Maybe someone here has a clue?

    For this to work on a server with one Genesis theme and on another sever http://newparadigmsolutions.org/  with a different Genesis theme has me puzzled.

    Thanks.

    • This reply was modified 1 year, 5 months ago by  dev.
    • This reply was modified 1 year, 5 months ago by  dev.
    • This reply was modified 1 year, 5 months ago by  dev.
    • This reply was modified 1 year, 5 months ago by  dev.
    #38566

    dev
    Participant
    Post count: 457

    re: http://newparadigmsolutions.org/

    I spent a lot of time yesterday trying to find out why Nick’s Responsive Header plugin does not work on one client’s server. I am now not sure it is the plugin. It may be the server or their install of WP… so I wanted to ask if anyone might have a clue.

    Here is the process:

    When I click the ‘upload’ button I get the media loader box, asking me to choose an image… same one you get when you insert a pix into a page…  standard WP code. (The plugin puts in a button saying “I want this for my logo.”) When I navigate and choose an image and click the button I go back to the plugin page.. but there is no URL in the text box… it is as if nothing happened.

    I’ve been contact with the developer of the Appfinite Legacy theme (nice man… good service… we like him and his themes a lot) and he says it works for him on his site with Legacy.

    So I’m thinking that it may have something to do with either file ownership or permissions. I looked on the client site via FTP and all files are owned by the user except the uploads folder with is owned by Apache’s “nobody.”  I don’t see that being an issue but I don’t have anything to compare it to. On our site we run under special CGI script that lets us own all files (we have a dedicated server with pair.com)

    What I’ve tried:

    -I deactivated all other plugins… only using the Gen slider on that site anyway.

    - I also tried plugin with different images… no change

    - I added define/concatenate scripts  in wp-config… no change.

    - I checked on permissions of the plugins javascript files… look fine.

    -  I left a message on Nick the Geeks board but my comments are still “waiting for moderation.”

    - I reinstalled the plugin, deactivated and re-activated… no change.

    So perhaps some of you who might know the internals of WP would be willing to suggest some ideas on why this plugin is not working. There has to be a reason… but I’m stumped so I’m looking for ideas from all of you.

    Thanks.

    #38636

    dev
    Participant
    Post count: 457

    SOLVED!

    Who is the dumbest web guy on the planet? I’m raising my hand here! Nick wrote me and said to simply paste in the URL of the logo-graphic (from Media Lib) and click “save.” Worked just fine. I never would have thought about bypassing the WP Thickbox media loader logic. I figured that it did something special to the graphic. It doesn’t. It just finds the URL… which anyone can get from the Media Library!

    Man, am I stupid or what?

    (Oh, he said the issue might be a javascript conflict between his plugin and the theme.)

    Thanks, Nick. You da man!! (And I’m the idiot!)

    #39647

    ahtimes
    Participant
    Post count: 2

    I am having a strange issue with Nick’s responsive header plugin. All widths work great except for some reason the 768 px one always cuts a portion of my image off to the right. Any idea what would cause this? Here is the link to the site: http://prairiegemstables.com/new2013/

    Here is the link to the image I have uploaded, which as you can see is the full 768 px wide: http://prairiegemstables.com/new2013/wp-content/uploads/2013/05/header-mobile72.jpg

    Any ideas? Thanks!

    #39653

    dev
    Participant
    Post count: 457

    .footer-widgets, #wrap {max-width: none;}

    Try the above CSS override in your child theme CSS (at end of file)  and see if that fixes the problem.

    It might cause other issues so make sure you test it on all your pages.

    Al
    http://www.NewMediaWebsiteDesign.com

     

     

     

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Header logo not responsive. Can it be?’ is closed to new replies.