Help – Have Published, But New WordPress Blog Won't Display

Community Forums Forums General Discussion Help – Have Published, But New WordPress Blog Won't Display

This topic is: resolved

Tagged: 

This topic contains 3 replies, has 3 voices, and was last updated by  martinr 1 year, 11 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #8029

    martinr
    Participant
    Post count: 1

    I’m building my first ever WordPress site. I can publish my home page (http://www.authormartinroth.com/) but none of the other pages will display.

    For example, I have tried to publish an About page (http://www.authormartinroth.com/about-martin-roth/) but get an “HTTP Error 404.0 – Not Found” message. It says the requested URL is http://www.authormartinroth.com:80/about-martin-roth/.

    Can someone please tell me what I’m doing wrong?

    Thank you.

    #8038

    Chris Cree
    Participant
    Post count: 147

    For starters it looks like you are using a Windows server instead of a Linux box.

    WordPress can work on a Windows server. But unless you really know what you’re doing, it’s going to be frustrating at best. Here is the Codex entry that might help: http://codex.wordpress.org/Installing_on_Microsoft_IIS Step 5 about how to enable pretty URLs in particular is worth reviewing.

    My suggestion since you are just getting started is to switch to Linux hosting. It will save you tons of heartache and grief.


    #8068

    AC
    Blocked
    Post count: 7712

    Did you create the post and then edit the date, time or title? Go to Settings > Permalinks and change the permalinks and then check again.

    #8096

    martinr
    Participant
    Post count: 1

    Thank you for the guidance. Thanks to Anita’s suggestions I went through all the permalinks, and though everything looked okay I made some changes, and now everything I publish is displaying correctly.

     

    Thank you again.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.