Help Needed

This topic is: not resolved

This topic contains 10 replies, has 3 voices, and was last updated by  thewahm 11 months, 1 week ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #40781

    thewahm
    Participant
    Post count: 6

    I needed to edit my header to add an image with links to different areas. For some reason it is working only on my main page. When you click on the sub pages within the site all you see are links at the top of the page in the header area. I used the genesis hooks and placed the table with images into that area. The url is http://www.wicklessfragrance.com. I would appreciate any help.

    #40783

    braddalton
    Participant
    Post count: 7454

    Paste the code here please and wrap it in opening and closing php tags with shortcodes. [ php ]


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #40784

    anitac
    Participant
    Post count: 6383

    What hook did you use and what hook area did you place it in? You code is saying only place it on the home and not every page.


    Let me help you customize your theme, responsive header, Buddypress, Agentpress or technical issue!
    Visit me here: Cre8tiveDiva.com | Tweet Me! | Plus Me!
    When asking for help, please provide a link or screen shot showing your problem!

    #40786

    thewahm
    Participant
    Post count: 6

    `genesis_header` Hook
    This hook outputs the default header (the `#header` div)

    and i checked the box.

    #40789

    thewahm
    Participant
    Post count: 6

    I added <table id=”Table_01″ width=”979″ border=”0″ cellspacing=”0″ cellpadding=”0″>
    <tbody>
    <tr>
    <td colspan=”2″><a href=”http://www.scentsy.net” rel=”nofollow”><img alt=”" src=”images/Scentsy_Top.png” width=”979″ height=”41″/></a></td>
    </tr>
    <tr>
    <td rowspan=”3″><img alt=”" src=”images/Scentsy_Products.png” width=”702″ height=”109″ /></td>
    <td><a href=”http://www.wicklessfragrance.com/go/shop-online/”><img title=”Order Scentsy Products” alt=”buy scentsy”src=”images/Button-1.png” width=”277″ height=”33″/></a></td>
    </tr>
    <tr>
    <td><a href=”http://www.wicklessfragrance.com/sell-scents/”><img alt=”buy scentsy products” src=”images/Button-2.png” width=”277″ height=”25″/></a></td>
    </tr>
    <tr>
    <td><a href=”http://www.wicklessfragrance.com/earn-free-scentsy/”><img alt=”no flame candles” src=”images/Scentsy_Safe_Candles.png” width=”277″ height=”51″/></a></td>
    </tr>
    </tbody>
    </table>

    #40791

    braddalton
    Participant
    Post count: 7454

    Remove the conditional tag and it will display site wide. But i don’t see a conditional tag in that code.

    You could also create the table using a table plugin and then echo in the shortcode for the table using a custom function.

    Or echo in the 3 links in a list. No need for a table then.


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #40796

    thewahm
    Participant
    Post count: 6

    Sorry I have no clue how to do that!

    #40800

    braddalton
    Participant
    Post count: 7454

    There’s some kind of conflict with the code. Really not sure whats causing it as i see the links do work on some pages but are messed up. Its conflicting with your header code somehow.


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #40804

    braddalton
    Participant
    Post count: 7454

    Try taking the code out of there and adding it to the header right widget.


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #40806

    thewahm
    Participant
    Post count: 6

    OK I removed it from hooks and added to header widget but its still doing it.

    #40866

    thewahm
    Participant
    Post count: 6

    Could I have possibly removed some kind of css data?

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.