Help with a footer theme…

Community Forums Forums General Discussion Help with a footer theme…

This topic is: resolved

Tagged: ,

This topic contains 9 replies, has 2 voices, and was last updated by  liferightfoundation 11 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #69904

    liferightfoundation
    Member
    Post count: 19

    Hi there.
    I am a newbie to coding (it scares the pants off me at the moment!) and I have added the 4-footer-widgets to my site (http://www.liferight.co.uk) and have repeated the text entry but it’s all gone over to the far left and not as the footer should be, i.e. in 4 columns of text, etc.

    Can you please help me with something simplistic, perhaps very similar to the bottom of this page would be great.

    Thank you for your help
    Phil

    http://www.liferight.co.uk
    #69943

    nutsandbolts
    Moderator
    Post count: 3131

    Looks like your footer widgets need some styling! The function is working, but there aren’t any CSS rules to tell them how to look. This tutorial uses 3 footer widgets instead of 4, but it might be a good place to start since it includes some CSS: http://tech4sky.com/adding-footer-widget-genesis-easy/


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #69955

    liferightfoundation
    Member
    Post count: 19

    Thanks Andrea. rather predictably it didn’t work! No doubt something I am doing wrong!
    I tried cutting and pasting the code, taking out all the line numbers (and also trying with them left in too) but it made no difference to the site :(
    [sighs]!

    #69956

    nutsandbolts
    Moderator
    Post count: 3131

    (1) Are you using a caching plugin or something like Cloudflare? (2) Did you go back and put widgets in the widget areas after you followed the tutorial?


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #69958

    liferightfoundation
    Member
    Post count: 19

    No [puzzled look!]
    The content was still in the widgets. Should I take it out and replace them?
    Thanks for your help… Feel a bit of a dummy!

    #69960

    nutsandbolts
    Moderator
    Post count: 3131

    No, that’s fine. If it’s still there, that’s a good thing. Sometimes it will take them out if you make changes to the way the function is written.

    Did you try the 3 footer widgets instead of 4? That could be the problem – the code in the tutorial is for 3 columns, which I honestly think would be better since the Freelance child theme isn’t very wide.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #69964

    liferightfoundation
    Member
    Post count: 19

    I changed it to 3 so that the code would be correct…

    #69965

    nutsandbolts
    Moderator
    Post count: 3131

    Hmm, that’s strange. Did the widgets show up at all once the code was inserted?


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #69987

    liferightfoundation
    Member
    Post count: 19

    They were already there, as I had put the widgets in first… but they all dumped the content over the left side.
    You were right about it needing styling!!

    Might it be better to start from scratch?
    Thanks
    Phil

    #70002

    liferightfoundation
    Member
    Post count: 19

    Hey Andrea, I took everything out and started again and it’s worked OK. I am happy it’s working although would have been happier to know what I was doing wrong!!
    Thank you for your help :)

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.