Home Page Balance Theme: Where are You?

Community Forums Forums Design Tips and Tricks Home Page Balance Theme: Where are You?

This topic is: not resolved

This topic contains 4 replies, has 3 voices, and was last updated by  nutsandbolts 10 months, 4 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #70992

    PatCarroll
    Member
    Post count: 5

    Good evening!
    I have been spending the day playing around creating pages, uploading plug-ins and was more or less ready to go but I couldn’t get it to look pretty. Noob warning up front.

    Then I found the very helpful theme instructions, with the recommendation to upload the XML file so I could see what names went with what appearance in the page.

    I made pages called About, Planning Cmte, Terms and Conditions and Contact Us. There was a fourth page that was called Welcome to Nurse’s Notebook which had very little on it, so I deleted it because I can’t figure out where the $#&^ home page is! I thought that since I had it listed as my front page, it was overriding the natural home page, but no. I have configured the home widgets, just as the instructions describe, but that mystery page is hiding! I don’t have “home” in the template list and don’t know where else to look.

    I did pretty well installing CustomForm7 and the CAPCHA addition and got it in along with the Shareaholic, and I tested it all, so I am not totally incompetent ;-) and I have to figure that this is staring me right in the face and I just can’t see it.

    Don’t care about the portfolio — just want the home.php ready to customize and then move on.

    **How do I get a front page that I can configure with those widgets so it will look like the demo?***

    I’ve sent aside tomorrow to load in a course I’ve written for which I am using LearnDash as my LMS — already loaded and ready to go.

    Once I get the home thing fixed, I’ll just get rid of the other pages.

    Thank you in advance for your patience! I will be back first thing in the AM.

    • This topic was modified 11 months ago by  PatCarroll. Reason: tried to paste in a clip from the dashboard
    • This topic was modified 11 months ago by  PatCarroll. Reason: tried to paste in a clip from the dashboard
    http://www.NursesNotebook.com
    #71011

    TravisPri
    Participant
    Post count: 29

    Hi there,

    You were on the right track! I’m pretty sure that rather than choosing a static homepage, you should go to Settings>Reading and then on the very first question, “Front page displays:” choose “Your latest posts”. Then populate your widget areas and they should appear on the homepage.

    Good luck!

    #71038

    PatCarroll
    Member
    Post count: 5

    That did it! Thanks! But, is there any way to have a static welcome front page or is the way the theme is structured incompatible with that?

    I will not be blogging on this site — I am setting it up to offer courses with LearnDash. I suppose I could make the posts my initial content the way they are on the demo page, but am just wondering for moving forward if I can have static content with the demo balance home page layout.

    Thanks for your help!

    #71163

    TravisPri
    Participant
    Post count: 29

    Hi Pat,

    If you want to stop recent posts from appearing on your homepage, you will need to edit home.php.

    I am not a php master by any stretch of the imagination, but I think I know what to do and want to help if I can. Before editing home.php, make sure you save a copy of it and that you have ftp access to the site so that you can re-upload the working copy if something goes wrong. (If there is an error in the php, you will get the dreaded white screen of death.)

    The code below is what I believe needs to be deleted from home.php.

    add_action( 'genesis_loop', 'child_grid_loop_helper' );
    /** Add support for Genesis Grid Loop **/
    function child_grid_loop_helper() {
    
    	if ( function_exists( 'genesis_grid_loop' ) ) {
    	
    		genesis_grid_loop( array(
    			'features' => 1,
    			'feature_image_size' => 0,
    			'feature_image_class' => 'align none post-image',
    			'feature_content_limit' => 0,
    			'grid_image_size' => 'grid',
    			'grid_image_class' => 'align none post-image',
    			'grid_content_limit' => 0,
    			'more' => __( 'Continue reading...', 'genesis' ),
    			'posts_per_page' => 5,
    		) );
    
    	}
    
    	else {
    		genesis_standard_loop();
    	}
    
    }

    So the last line of your code in home.php would be:

    remove_action( 'genesis_loop', 'genesis_do_loop' );

    Again, be sure you have a working copy of home.php in case something goes wrong. Hope this helps! Let me know how it goes :)

    #71171

    nutsandbolts
    Moderator
    Post count: 3131

    If you want to disable the widgetized homepage, instead of editing home.php, just rename it. I usually tell people to rename the file to something like home-old.php – that will keep the other theme files from being able to find it. Then you can set a static homepage instead of using the widget areas.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.