"Home" Page not using correct template; can a category be used instead?

Community Forums Forums Design Tips and Tricks "Home" Page not using correct template; can a category be used instead?

This topic is: not resolved

This topic contains 4 replies, has 2 voices, and was last updated by  dogleg.com 1 year, 2 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #16917

    dogleg.com
    Participant
    Post count: 27

    I messed something up…using “Prose”…

    I was removing some unneeded plugins, and now when I go to my blog, the first page you get to (which is called “home” in the breadcrumbs) is out of alignment–it is not the 3-column layout like all the others. The info is still there, but the left margin is huge, and the info that was in the right-hand sidebar is WAY down at the bottom of the column.

    If you navigate to any of the other “categories/pages” in the menu, the breadcrumbs show the correct location and the pages are all in the correct layout (which is set as the default).

    My question is: I don’t technically have any pages–all my things are organized into categories, and the categories are made into a menu, which works just fine.  I don’t understand why, but apparently there has to be a “home” area–but where is it coming from? I don’t have any pages created nor is there a place called “home” on my custom menu, but the place is there nonetheless.

    I would rather get rid of “home” altogether, and just use my “blog/memoir” category as a “home” page, but if the home has to be there, then how do I get my columns lined up again?

    Thanks so much for any help…

    Paula

    doglegbipolarjourney.com

     

     

    #16924

    SoZo
    Moderator
    Post count: 1573

    I’m not seeing anything off on your front page but to answer your questions you have to have a home or front page of your site. That is what people see when they access your URL. In prose there is no home.php template like you find in most of the other SP themes so what you get is an archive of your latest posts, i.e. a traditional blog’s front page. If you want to limit that to one category of posts you could create a page and set that page to use the blog page template (you’ll see the template drop down over in the right column of the page editor under attributes). Then go to the Genesis settings panel, scroll down to the blog template module and set a category there. Then go to Settings=>Reading and select your new page from the Front Page drop down.


    John “Nicolas Flamel” Wright | SoZo’s design| John Wright Photography

    #16925

    dogleg.com
    Participant
    Post count: 27

    OK, will try that. Thanks!

     

    #16959

    dogleg.com
    Participant
    Post count: 27

    Oh no!

    I created a “page” called “home” and set it as a “blog” page (and default is still my 3-column page) and in Settings—–Reading I selected the page as front page (it designates it as a static page, which I am not sure if that is right)…

    and now ALL my pages are one column and all messed up (header not aligned correctly, footer area all messed up, one widget in footer not showing)–What have I done?

    THANKS!

    #16969

    dogleg.com
    Participant
    Post count: 27

    I am going to start a new thread, since I don’t think I explained my problem well enough, and now I have fixed my formatting problem by changing my “home” page setting, but I am back to where I started…

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.