Homepage Pagination Giving me the Finger

Community Forums Forums Design Tips and Tricks Homepage Pagination Giving me the Finger

This topic is: not resolved

This topic contains 5 replies, has 2 voices, and was last updated by  David Chu 1 year, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #53535

    Tomchalky
    Participant
    Post count: 5

    Hey guys,

    I know the issue I’m having is a bug/ongoing issue with WordPress, but all the solutions that I have come across talk about queries (that I do not understand – Designer not developer) and generally editing the core files of WordPress which usually wouldn’t be an issue as they would be straight in the theme, but with Genesis of course its a different story.

    Heres the low-down, I have set the homepage of my website to be a static page, this static page has a blog page template with the grid loop plugin by Bill. I have checked all other plugins and there doesn’t seem to be any conflicts. The issue lays within the pagination, when I click page/2/ or even page/52/ it continues to show the content from page/1/ even though the URL has changed appropriately. This only happens on the homepage.

    Is there a simple fix? Genesis hook or something I can throw into my functions file. Any help will be greatly appreciated.

    Ps – I have searched the forums for a definitive fix, but I couldn’t come across anything.

    http://inspirationhut.net
    #53557

    David Chu
    Participant
    Post count: 1409

    Hi,
    Not positive, it’s very hard to tell from outside, but a couple thoughts for you. When you described the problem, I instantly thought Yoast and Page Navi. I called that right. :-)

    But Yoast can work in that scenario. My next thought was the cache. I know Yoast may not play well with Total Cache at times, and various fixes on both ends have been done.

    You have Super Cache there. I would suggest trying no cache on the Home page. Settings for that on Advanced tab, Accepted Filenames & Rejected URIs.

    Beyond that, hard to say without digging deeply.

    Dave


    Dave Chu · Custom WordPress Developer – likes collaborating with Designers

    #53628

    Tomchalky
    Participant
    Post count: 5

    Hey Dave,

    Thanks for replying and for your tips, I installed page navi to try and resolve the situation, but for some reason after activating it, it doesn’t show on genesis. The standard pagination remains, so I figured that was a dead end that I just couldn’t be bothered to get around as I doubted it would fix the issue.

    As for the super cache, I have uncached the homepage and front page but unfortunately nothing is working.

    This might help a little, the pagination works when I set the frontpage to show the recent posts, however not when I set it to a static page.

    #53665

    David Chu
    Participant
    Post count: 1409

    Tom,
    What you said there gave me one more thought…. Page Navi does not automagically work by installing the plugin… pardon me if you’ve done this, but did you install the template tag as per these instructions?
    [php]
    wp_pagenavi();
    [/php]

    And if it’s in the part of a template that’s HTML, you’ll have to surround it with php tags. That would need to go somewhere in your home.php template, if that’s what you have in that theme. Otherwise, Page Navi will do nothing. This is starting to make sense, because usually these types of paging template tags are in archive templates, not a more static type of template. I just did testing with Page Navi in Genesis 2.0 release candidate, so all that is fresh in my mind.

    Dave


    Dave Chu · Custom WordPress Developer – likes collaborating with Designers

    #53736

    Tomchalky
    Participant
    Post count: 5

    Hey Dave,

    I actually didn’t do that, now I have. The page navi is now showing but unfortunately it only shows 1 page, I’m going to guess this is the issue :P

    Heres a screenshot with the Page navi below our original navigation. Whats your verdict on this?

    Screenshot

    #53744

    David Chu
    Participant
    Post count: 1409

    Tom,
    That’s about as far as I can go without tearing the whole thing apart, so this is probably the end of the line for me here, I’m afraid. Often in these complex scenarios there’s something hidden that is causing shenanigans. Custom permalink settings could be messing something up. On and on.

    I know that this is apparently sort of a portal site. Otherwise, I’d question the huge number of items you’re trying to navigate through in one shot. No one, and I mean no one, pages through 50 pages, even if they’re the most genius items of all time. Not even the site owner’s Mom! I know that’s probably hard to hear.

    I suppose you could try testing with fewer items being pulled into home. Maybe some custom query somewhere isn’t working, or maybe it just died due to sheer quantity.

    If it were me, I would probably try using a nice Category menu to help organize things in a way that people might be wiling to investigate, as opposed to long, long linear paging. Usability. :-)

    Good luck!
    Dave


    Dave Chu · Custom WordPress Developer – likes collaborating with Designers

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.