Hooking New Widget Area to Proper Position

Community Forums Forums Design Tips and Tricks Hooking New Widget Area to Proper Position

This topic is: resolved

This topic contains 4 replies, has 2 voices, and was last updated by  Michael 9 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #87324

    Michael
    Participant
    Post count: 37

    Greetings Studio Press Forum!

    I am working on developing a new website and having some difficulties getting things to look just right. I am using Outreach child theme.

    Please see-

    http://www.happyrealpeople.com/

    I have successfully created the widget areas called, Home Slider, which has the main image right now, and Slogan, which has a text widget installed with the slogan image in green letters. Everything is configured how I want it to look from the top down to the bottom of the Slogan image. The trouble is, I can’t seem to get rid of the white area below the slogan image, which is where I think the old “Home Featured” widget area used to be. I tried removing the call for Home Featured from the functions.php file and home.php, and the widget area is now gone on the backend, but that white area below the slogan, I can’t seem to get rid of it on the front end.

    Thank you for any insights you can provide!

    Michael

    http://www.happyrealpeople.com/
    #87329

    asterbird
    Participant
    Post count: 101

    Hi, is your homepage an actual WP Page or latest posts (Look in Settings > Reading I think)? looks like it’s an actual page, and the white space is the content padding. Try:

    .home .full-width-content.outreach #content {
        padding: 0;
    }
    #87332

    Michael
    Participant
    Post count: 37

    Hi asterbird-

    Thank you for your suggested fixes!

    From what I understand about the Genesis child themes, you’re supposed to leave the Setting/Reading to “Your Latests Posts” and as soon as you start adding content to the widget areas, it removes the blog page area from the home page. If I select “Static Page”, I can change that but only to one of the pages, not the Home page I am trying to achieve. From what I understand, this is how the home page is configured if you don’t want it to look like a blog.

    I tried the code you suggested at the end of the style sheet css file, but didn’t notice any changes.

    Of note, I was able to change the background color in firebug for #content from #ffffff to #000000 and that got rid of the white space. However, it also changed the background on all the pages to black too. Perhaps this is a clue that can help identify the problem but I have been unable to decipher it.

    Thanks again!

    #87337

    asterbird
    Participant
    Post count: 101

    oops, my bad. The class home is on the same element as full-width-content, so drop the space:

    .home.full-width-content.outreach #content {
        padding: 0;
    }

    Actually looks like this works too (less characters is always better!):

    .home.full-width-content #content {
       padding: 0;
    }
    #87345

    Michael
    Participant
    Post count: 37

    Awesome! Thank you asterbird, worked like a charm.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.