How do I change the post info for posts only and not pages

Community Forums Forums Design Tips and Tricks How do I change the post info for posts only and not pages

This topic is: not resolved

Tagged: 

This topic contains 6 replies, has 3 voices, and was last updated by  braddalton 7 months, 2 weeks ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #44178

    srousseu
    Participant
    Post count: 1

    I have tried to change the post info using genesis simple hooks and by putting the following code into the  genesis_before_post_content Hook box.

    <div class="post-info">
        Last updated on <span class="time"><?php the_modified_time('F j, Y'); ?></span> <span class="author">by <?php the_author_posts_link(); ?></span> <span class="post-comments"><a href="<?php the_permalink(); ?>#respond"><?php comments_number('Leave a Comment', '1 Comment', '% Comments'); ?></a></span> <a class="post-edit-link"><?php edit_post_link('(Edit)', '', ''); ?></a>  
    </div>

    It worked, but now it puts the post info (Date, Name, etc.)  on not only my posts, but all my pages too!  How can I change it for just posts?

    Thanks in advance!

    http://www.healthywealthyexpat.com
    #44328

    braddalton
    Participant
    Post count: 7440

    Add a conditional tag for posts only:

    is_single()
    

    or

    !is_single()
    

    Code not displaying? Grab it on Github.

    This code needs to be pasted at the end of your child themes functions.php file from the view raw link using a text editor.


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #46251

    esanger
    Participant
    Post count: 7

    Brad… always value your advice!

    I had the same problem with adding the post info in Simple Edits.  The post info showed not only on my posts, but also my pages.

    Took your advice.  Copied the view raw link and pasted it at the end of my child themes function.php file.

    (had to delete my Simple Edits code first.. gave a system error)

    Now, nothing is showing at the top of my posts.  Previously, it showed.

    Any ideas?  Thanks in advance.

    #46261

    braddalton
    Participant
    Post count: 7440

    Its showing on this post http://www.healthywealthyexpat.com/welcome/

    Can you please link to a post it snot displaying on thanks.


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #59199

    srousseu
    Participant
    Post count: 1

    Thanks for the advice, Brad. Sorry, I’ve been on a two month hiatus and just back working on my site. That wasn’t me replying above your last comment, but I did try what you suggested and it still shows up on all my pages (forum, archives, etc.) I only want the ‘Last updated on…’ to show up on posts. Any other ideas anyone? Thanks!

    #59359

    braddalton
    Participant
    Post count: 7440

    PHP code generally will not work if you have the Genesis Simple Edits plugin activated as well because it over rides the code.

    The CSS classes are also different for XHTML and HTML 5 enables child themes.

    This is what i use in the functions file. Credit to Greg Rickaby who wrote the original code i modified.

    https://gist.github.com/braddalton/6373014


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

    #59361

    braddalton
    Participant
    Post count: 7440

    The above code uses the new HTML 5 loop hooks.

    The old ones are here


    WordPress Developer & Consultant
    Brad Dalton400+ StudioPress Tutorials & 1200+ Code snippets

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.