How to change footer text size without changing any other text size

Community Forums Forums Design Tips and Tricks How to change footer text size without changing any other text size

This topic is: not resolved

This topic contains 12 replies, has 3 voices, and was last updated by  grahamg4 1 year, 11 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #13463

    grahamg4
    Participant
    Post count: 6

    Hi –

    I have the current framework and am using the Focus child theme. I’m trying to edit the text size in the “Enter scripts or code you would like output to wp_footer():” area of the “Genesis Theme Setting”. This is the only location i have been able to get any text to populate. However, this area is controlled by the body text size.

     

    Is it possible to set the footer font size to a different size than the body font size?

    I’m new to Genesis but am comfortable editing files.

    Thanks for your help in advance.

    Al

     

    #13468

    braddalton
    Participant
    Post count: 10675

    You could write the text in your editor and change it there so then you can paste the HTML into the box to output in the footer.

    I used the fonts plugin to change the size of the text.

    You could also output the same HTML for your text using the Genesis Simple Hooks plugin.

    Another way is to use Firebug and change the values in your CSS declaration so your font size is different.

    http://www.w3schools.com/cssref/pr_font_font-size.asp

    [css]
    #footer a, #footer a:visited {
    font-size: 25px;
    }
    [/css]

    CSS is far more powerful and flexible so its the better method


    #13622

    grahamg4
    Participant
    Post count: 6

    Thanks Brad but, not working or I’m doing something wrong.

    1 – Text editor outputs a size 8 copy/paste the text in to the Genesis Settings Footer box, save, refresh webpage, Footer size =12.

    2 – Text editor outputs a size 8 in HTML, copy/paste the text in to the Genesis Settings Footer box, save, refresh webpage, Footer size     =48 or LARGER while rest body text size = 16. Exactly the opposite of what I desire.

    3 – Simple Hooks Plug-in and Firebug BOTH generate nothing – no text whatsoever.

    It’s a required govt disclaimer and it is long : 2000 character on 23 lines. Maybe I’ll try turning it in to an image file. This is taking up too much of my time. Funny, before I re-purposed this site I ditched the entire hosting and did a clean WP install. Decided that Genesis would be the way to go forward and not use “no longer supported free” WP Themes. But, nothing seems to be working the way it is supposed to, from child theme to plug ins.

    Al

    #13623

    AC
    Blocked
    Post count: 7712

    I would leave the footer in the Genesis Settings alone and just modify the footer font size using the CSS just as Brad suggested. That’s the best and easiest way to do it.

    #13624

    grahamg4
    Participant
    Post count: 6

    I’ve changed the child theme style css font-size from 11px incrementally down to 2px and nothing changes.  Posts are 16px and Footer text is 16px. The only time it changes is when the Genesis style css is edited and then BOTH change the same from 16 to whatever was edited.

    FROM:

    #footer {
    border-top: 5px solid #f0f4f6;
    clear: both;
    color: #617984;
    font-family: Arial, Tahoma, sans-serif;
    font-size: 11px;
    margin: 0 auto;
    overflow: hidden;
    text-transform: uppercase;
    width: 100%;
    }

    TO:

    #footer {
    border-top: 5px solid #f0f4f6;
    clear: both;
    color: #617984;
    font-family: Arial, Tahoma, sans-serif;
    font-size: 2px;
    margin: 0 auto;
    overflow: hidden;
    text-transform: uppercase;
    width: 100%;
    }

    #13625

    AC
    Blocked
    Post count: 7712

    What is the URL to your website so I can take a look?

    #13630

    braddalton
    Participant
    Post count: 10675

    I tested this using the fonts plugin and HTML and it worked. Its still on my demo. But i also used CSS and it worked on my demo using the code i supplied.

    I think CSS is more complicated but far more powerful. Depends on your level of experience,

    Best way to learn is to install your theme on a local installation and play around with it using Firebug.


    #13673

    grahamg4
    Participant
    Post count: 6

    Fonts plugin is nice but, it is not available on the WP_footer area of the Genesis Theme Settings.

    As for the code, where exactly should it be inserted? Genesis or Child? Style of Function? Where at in the code?

    I’ve inserted in multiple locations on all of the files. Copy / paste of the code from above

    #footer a, #footer a:visited {
        font-size: 25px;
    }

    My site, up1level.com the text I’m having problems with is the “Disclosure” at the very bottom. I want it to be 8 or smaller and the size to be independent of the rest of all posts & pages.  I do have a WP setup locally but had to rush this after an email was accidentally sent. Now I just need to clean some areas up.

    I appreciate the help.

    #13686

    AC
    Blocked
    Post count: 7712

    The reason why it’s not working is because you have added the text to the body. Where exactly did you place the text in your code? That area is technically not the footer for Genesis/Child Theme purposes.

    I don’t code, but I just got this to work for me. If you haven’t already installed the “Genesis Simple Hooks” plugin, install and activate it.

    Then, look for the box labeled – genesis_footer hook. Paste this in the box and save it – REPLACING the TEXT with your own text. Be sure to check the box that says UNHOOK genesis_do_footer….

    The code will not copy in here so click this link – https://gist.github.com/01a089c15513a5733b7d.git

    Then go to your Style.css file and look for this. Your font size may be different, but change it to the size you want and save it.

    #footer .wrap {
    font-size: 14px;
    }

    This works for me so it should work for you so you won’t be using the BODY of the code.

    #13708

    grahamg4
    Participant
    Post count: 6

    Tried it and nothing shows up on the site. I also tried it with each configuration of checking BOTH “Enable” option boxes.
    Code from link <br/><br/><div><center>This is MORE plain text.</center></div>

     

    #13715

    AC
    Blocked
    Post count: 7712

    Go to my website, look in the footer and send me your email address so I can send you something.

    #13720

    grahamg4
    Participant
    Post count: 6
    This reply has been marked as private.
    #14015

    grahamg4
    Participant
    Post count: 6

    Thanks again Anita for trying. I submitted the ticket yesterday afternoon. Brad thank you also, not sure why the options you suggested are not working.

    Al

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.