How to disable social sharing buttons from showing on home page – Outreach theme

Community Forums Forums General Discussion How to disable social sharing buttons from showing on home page – Outreach theme

This topic is: not resolved

This topic contains 11 replies, has 4 voices, and was last updated by  jlong230 7 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #79813

    jlong230
    Participant
    Post count: 17

    This question could apply to any Studiopress child theme…

    I have tried several social sharing plugins (add this, share this, sharaholic, etc) and want to only have it display on posts or pages. But, they all show up on my home page featured page widgets. I’m have the checkbox checked for “show page content”. I’m using the “more” tag for each page to force what text is displayed on the home page text area and the social sharing icons appear on the home page. I notice that when I use “Content Character Limit”, the social sharing plugins don’t show up, but I’m unable to put the exact text that I want in the home page feature page widget area on the home page. It automatically adds too many words, even when I use the exact characters needed.

    How can I use a social sharing plugin but not have it display on the home page? This seems like it should be easy! Thanks for the help.

    http://www.rslcs.org/
    #79887

    nutsandbolts
    Moderator
    Post count: 3104

    Can you enable the social sharing plugin again? If I can see it on the page, I can probably tell you how to hide it for the homepage only.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #79976

    barbaradavis
    Participant
    Post count: 2

    Hello, I have almost exactly the same problem. I’m using the Outreach theme, and have tried many of the same social networking Share plugins, but can’t get the configuration I want: to have social networking icon/links occur only on left-column homepage posts and/or categories, but NOT in the widget sidebar. Also, separately for individual posts on other pages (custom application of social icons per individual posts).

    I too get unwanted text, and tag!, showing up near the icons when the plugins are activated.

    In general, would love to have simple FB, Twitter, and Instagram buttons for sharing, placed at bottom of individual selected posts (not in widget sidebar), with no extra text showing.

    Could probably hard-code individual button images with an href link for each individual post, but this is not a good solution for my client.

    Thank you Andrea and thanks jlong230 for the question!

    http://www.marcikipnis.com

    #80013

    jlong230
    Participant
    Post count: 17

    I’ve activated the Sharaholic plugin again, but I can only do it for a day or so. Barbara, I hope Andrea can help us out :)

    #80037

    nutsandbolts
    Moderator
    Post count: 3104

    In your Shareaholic settings, are the sharing options for Index unchecked? It’s checked by default. I’ve just unchecked it on a test site and the sharing buttons aren’t showing on the Home Featured areas.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #80507

    jlong230
    Participant
    Post count: 17

    Yes, the Index option is unchecked for both Sharing and Related Content. I’ve tried about 5 other sharing plugins and they all show up on the home page widgets.

    #80868

    jlong230
    Participant
    Post count: 17

    Were you able to find a solution?

    #80869

    genwrock
    Member
    Post count: 321

    add this code in style.css file

    
    .home .shareaholic-share-buttons-heading{display: none}

    Working as a freelancer & helping the people on forum | Chinmoy @ PWD | Please Follow Me on Twitter If I’ve helped.

    #80871

    jlong230
    Participant
    Post count: 17

    That got rid of the “sharing is caring part”, but I’m wanting to get rid of all the sharing buttons on the home page. I’ve unchecked the Index options in the Sharaholic settings, but it’s still displays on the home page.

    I’ve tried multiple other social sharing plugins and they all show on the home page. If there is a better/easier social sharing plugin that I can customize not to show up on the home page then I’d gladly switch.

    Thanks for the help so far.

    #80873

    genwrock
    Member
    Post count: 321

    Sorry try this code

    .home .shareaholic-share-buttons, 
    .home .shareaholic-share-buttons-heading{display: none}

    Working as a freelancer & helping the people on forum | Chinmoy @ PWD | Please Follow Me on Twitter If I’ve helped.

    #80874

    genwrock
    Member
    Post count: 321

    Also you can use this

    .home .shareaholic-canvas{display: none}

    I think that this one will be best for you.


    Working as a freelancer & helping the people on forum | Chinmoy @ PWD | Please Follow Me on Twitter If I’ve helped.

    #80885

    jlong230
    Participant
    Post count: 17

    Thanks for the help! This worked like a charm. Thank you so much.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.