How to improve load time of Genesis

Community Forums Forums General Discussion How to improve load time of Genesis

This topic is: not resolved

Tagged: 

This topic contains 24 replies, has 6 voices, and was last updated by  nutsandbolts 10 months, 3 weeks ago.

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • #73140

    beoleary1
    Participant
    Post count: 51

    My ISP is bluehost and I’ve contacted them to figure out how to improve my site loading time that averages around 5-7 secs. I cleaned up my cache already using a recommended plugin on this forum. Here is a note from Bluehost:

    “The server load time is the time it takes the server to process the PHP in your site. In this case, your theme is making a call to a remote server for information which it is then passing to wp-cron.php — This is increasing that load time. Enabling caching so it doesn’t do this on every page load should help quite a bit.”

    Not sure what to do now. I was told if I can solve this, load time should be 1-2 seconds for my site.

    http://microsprayinternational.com/blood-collection-tube-coating/
    #73171

    nutsandbolts
    Keymaster
    Post count: 3176

    Let me be very blunt and tell you that Bluehost is horrible – their servers are ridiculously outdated and slow, and they LOVE to blame slow load times on “poorly coded PHP scripts.”

    Your theme is not making a call to a remote server; that doesn’t even make sense. There is nothing in the Genesis framework that requires information from another server. Your site isn’t loading for me right now so I can’t look to see what’s going on, but I can assure you, they’re full of it on this one.

    A caching plugin is never a bad idea, but I guarantee if you run a speed test with tools.pingdom.com once your site is back up, you’ll see a LOT of yellow in the waterfall of the elements loading on the page. Yellow indicates waiting for your host’s servers to send data, which makes it a Bluehost problem and not a problem with Genesis.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #74018

    beoleary1
    Participant
    Post count: 51

    My site was down because Bluehost botch a SSL install. Anyway, I’m back up and running. Can you suggest a good good alternative?

    #74019

    nutsandbolts
    Keymaster
    Post count: 3176

    I would recommend that you talk to Big Scoots Hosting. I’m not affiliated with them in any way – I don’t even host with them since I have my own servers. I just know from working on client sites that they are very knowledgable and provide excellent support. Just chat with their sales team about your current issues and let them explain what they can do for you. I refer people to them all the time and everyone (30+ clients) has been thrilled so far!


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #74027

    citidm
    Participant
    Post count: 30

    Hello, I am having the same issue on load time. My host is Yahoo Small Business. I am just running the Genesis Framework. and the site takes about 5-7 seconds to load. Do you think it’s just a server issue? Also are you using a shared hosting account, VPS or dedicated?

    Thanks

    #74028

    nutsandbolts
    Keymaster
    Post count: 3176

    I didn’t even realize Yahoo offered hosting but it horrifies me a little to think about it. Do you mind to post a link to your site? I can run a load test and see what’s causing the long load times.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #74032

    citidm
    Participant
    Post count: 30

    Here is the link to my website’s blog. The main site which is not part of wordpress loads fast but the wordpress part loads slow.

    Thanks for your help.

    #74033

    citidm
    Participant
    Post count: 30

    Hmmm I don’t see that the link loaded.

    http://bronxpad.com/Bronx-Homes-Blog/

    #74035

    nutsandbolts
    Keymaster
    Post count: 3176

    Okay, there are a lot of things going on here. No matter how much I’d like to blame Yahoo, the server response doesn’t seem to be the issue.

    First, you have 190 requests on the main blog page. That is a LOT – most sites have 50 at the absolute most. Requests mean the browser has to access various files, scripts, images, etc. to load the page, so each element is a request that will add to the time it takes your browser to show the site.

    The biggest culprit is your sharing buttons – is that the Add to Any plugin? I would look for a different one – it’s loading each button on each post from an external server. That’s over half the requests on the page.

    Second, you need a plugin to compress images as you upload them. WP Smush.it is somewhat buggy but it’s the most popular plugin for image compression. It should work even when you use Photo Dropper to pull images into the media library.

    I would change Settings > Reading to show fewer than 10 posts on each blog page. Since you’re showing full posts, I think it would make sense to decrease that to 3-5 at the most. That also reduces load time.

    Finally, I would install WP Super Cache to help some of your static content load a little faster.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #74037

    citidm
    Participant
    Post count: 30

    Thanks, Is there any SEO impact with changing the article feed to Summary vs Full Text? Also is there any SEO impact to changing the amount of posts per page from 10 to 5?

    I removed the Add to Any and it helped a lot by itself so far.

    Thanks again.

    #74038

    nutsandbolts
    Keymaster
    Post count: 3176

    Nope, no SEO impact in either case.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

    #74042

    citidm
    Participant
    Post count: 30

    Thanks again, I implemented most of what you mentioned and I see the requests have gone down to 38 and the site score went up to 95 but for some reason the load time just went up to 9.78 seconds even though the page size was reduced and requests reduced. Scratching my head.

    #74045

    citidm
    Participant
    Post count: 30

    Just tested again and it improved to 4.09 seconds. How should the Super Cache be set?

    #74051

    RobG
    Participant
    Post count: 1055

    Well just from looking at your website I can tell you the slowness is not caused by the content you have on your site because you really don’t have much, with that said, that only leads me to think it’s your hosting provide that’s to blame.

    When ever you have trouble with loading time take a look at your content and ask your self what do I have on my site that could be causing my website to be slow.

    One of the biggest things that will slow a website down it open images and advertisements place on your pages. A hosting service will NEVER say it’s caused by our servers and will always point the finger at someone else.

    This is just my two cents because I have been dealing with hosting servers for a very long time. Hope this helps.


    To speed up the process please post the link to the website in question.

    We recommend using Firebug to view source codes http://getfirebug.com/

    RobGoss WordPress Developer
    We build WordPress websites for your business or personal goals
    http://www.robgoss.com / Follow me Twitter / https://twitter.com/robgoss

    #74058

    nutsandbolts
    Keymaster
    Post count: 3176

    To set up Super Cache, you want to turn caching on under the Easy tab. Then under the Advanced tab, choose the following (I’ll go in order to make it easier):

    Cache hits to this website for quick access.
    Use mod_rewrite to serve cache files.
    Compress pages so they’re served more quickly to visitors.
    Don’t cache pages for known users.
    Cache rebuild. Serve a supercache file to anonymous users while a new file is being generated.
    Mobile device support.
    Clear all cache files when a post or page is published or updated.
    Extra homepage checks.

    Once you do all that and save, you’ll scroll down to see a brownish/yellowish box telling you to add the mod_rewrite rules. There’s a button to save that, then all those will display as green (meaning it worked). Then scroll down to the section called Expiry Time and Garbage Collection. Set the cache timeout to 3600 seconds and select Timer (not Clock) set to 1800 seconds. Click the Change Expiration button. After that, scroll down and check those settings again (sometimes they reset themselves) and click Change Expiration one more time.


    Andrea Whitmer, Owner, Nuts and Bolts Media
    I provide dev and training services for web designers • Find me on Twitter and Google+

Viewing 15 posts - 1 through 15 (of 25 total)

You must be logged in to reply to this topic.