How to make logo clickable in Metro theme

Community Forums Forums General Discussion How to make logo clickable in Metro theme

This topic is: not resolved

This topic contains 12 replies, has 2 voices, and was last updated by  castledesign 1 year, 3 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #36081

    castledesign
    Participant
    Post count: 7

    Hello!

    I have been using Metro theme which is great but I had to customize the top logo/header area to make the logo bigger.. Now it is no longer ‘clickable’ to the home page.  Can anyone help me fix this issue?

    The site is http://baby-mac.com/

     

    Thank you so much!

    http://baby-mac.com/
    #36087

    braddalton
    Participant
    Post count: 8826

    Add the link when you insert it into a new post and grab the HTML for the image which includes the link.

    How did you add the image? Did you upload it using the header uploader or add the CSS in your style.css file?


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #36088

    castledesign
    Participant
    Post count: 7

    I uploaded it in the header file and changed the functions file etc to suit the larger logo.. hope that makes sense.

    Thank you!

    #36089

    braddalton
    Participant
    Post count: 8826

    There’s no header file but there is a images file in your child theme.

    So you uploaded it manually using FTP to your child themes images folder rather than use the custom header uploader under Appearance?

    And you also changed the height in your child themes functions.php file?

    Did you change any of the header dimensions in the style.css file?


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #36090

    castledesign
    Participant
    Post count: 7

    mmmm… so maybe i did upload it via FTP?

    argh.. i was trying to sort it myself with help from this person and that person (via forums) I cant really remember now…

    With this vague response, can you suggest what i should do?

    #36091

    braddalton
    Participant
    Post count: 8826

    What exact size is the header?


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #36092

    castledesign
    Participant
    Post count: 7

    1080 x 150

     

    :)

    #36093

    braddalton
    Participant
    Post count: 8826

    I tested this on your Metro theme with your header and it works perfectly.

    Yes. You have 2 style sheets. Ones for the custom CSS but it does not contain a custom link to your home page in the CSS for the header image unlike what would be the case if you change the dimensions in the main style.css file and uploaded your header image using the built in custom header uploader.

    [css]
    // Line 519
    #header {
    min-height: 150px;
    overflow: hidden;
    }
    // Line 558
    .header-image #title,
    .header-image #title a,
    .header-image #title-area {
    display: block;
    float: left;
    min-height: 150px;
    overflow: hidden;
    text-indent: -9999px;
    }
    [/css]

    Make sure your functions.php file uses these values:
    [php]
    // Line 34
    add_theme_support( ‘genesis-custom-header’, array(
    ‘flex-height’ => true,
    ‘height’ => 150,
    ‘width’ => 1080
    ) );
    [/php]
    Your header image
    [html]

    http://baby-mac.com/wp-content/uploads/2013/04/header11.png

    [/html]


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #36097

    castledesign
    Participant
    Post count: 7

    Thank you SO MUCH Brad for your help.. I’ll give this a shot and let you know how I go.

    I really appreciate it :)

    #36098

    braddalton
    Participant
    Post count: 8826

    It worked for me but i didn’t have any overriding CSS in the custom-style.css file.


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #36465

    castledesign
    Participant
    Post count: 7

    Hey Brad!

    I have finally had a chance to sit down and try this.. I removed the coding from the custom CSS and made the changes and it all looks lok but still dosent seem to be linking?   Did I miss something?

     

    Thank you

    #36480

    braddalton
    Participant
    Post count: 8826

    I tested the solution and it worked for me.


    Specializing In StudioPress Child Theme Customization.
    500+ StudioPress Tutorials

    #36485

    castledesign
    Participant
    Post count: 7

    Where do you suggest I  put this code you mention above for the header image?

    <a href="http://baby-mac.com/wp-content/uploads/2013/04/header11.png" rel="nofollow">http://baby-mac.com/wp-content/uploads/2013/04/header11.png</a>

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.