How to remove Post feeds and Comments on homepage

Community Forums Forums Design Tips and Tricks How to remove Post feeds and Comments on homepage

This topic is: not resolved

This topic contains 9 replies, has 2 voices, and was last updated by  Marcy 6 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #87792

    Gordy
    Participant
    Post count: 86

    Is the “Posts” and “Comments” on top of website homepage very important?

    I would like to remove the “Posts” and “Comments” that is showing at the topmost part of the homepage of my site.

    http://afroscandic.com/
    #87844

    Marcy
    Participant
    Post count: 286

    You can remove the Posts and Comments links in your top header this way.
    Go to your WordPress Admin
    Click on Genesis > Theme Settings
    Find the section Navigation and Primary Navigation Extras
    In the drop down, choose None
    Save

    The links should be gone then


    #87890

    Gordy
    Participant
    Post count: 86

    Hi Marcy,

    I have tried that before. The options under the “Primary Navigation Extras” are : None, Search form, Today’s date, RSS feed links, and Twitter link

    So, when I chose “None” did not remove “Posts” and “Comments” link

    I am using the “old Streamline theme” and you can see the site at : http://afroscandic.com/

    #87891

    Marcy
    Participant
    Post count: 286

    OK.
    Try this instead. In you styles.css find this section:

    .topnav-right {
    width: 700px;
    float: right;
    margin: 0;
    padding: 5px 0 0 0;
    text-align: right;
    }

    and comment it out, and add display: none like this:

    .topnav-right {
    /*width: 700px;
    float: right;
    margin: 0;
    padding: 5px 0 0 0;
    text-align: right;*/
    display: none;
    }

    #87893

    Gordy
    Participant
    Post count: 86

    Thanks but, I would like to know from you if you have tried something like this before because, I don’t want to start getting errors on my site. I would only want to do it if there’s 100% guarantee that there will not be any problem, since it’s a live site that is running now.

    Is there no other way that Studiopress theme has for removing this? either in their tutorial or in the beginner’s tutorial?

    #87901

    Marcy
    Participant
    Post count: 286

    I have given you the easy way to remove it; editing your CSS.

    If you are worried about editing your style.css, you can use a Custom CSS editor like the Jetpack Custom CSS module. It looks to me like you’re using Jetpack.
    So in the Custom CSS editor, just add

    .topnav-right {
    display: none !important;
    }

    Then you don’t need to remove the other selectors. If you don’t like it, then you can just delete the bit of code you added, and all will be back to normal.


    #87903

    Gordy
    Participant
    Post count: 86

    Thanks for this help. Yes, am using Jetpack. Should I place

    .topnav-right {
    display: none !important;
    }

    anywhere after :

    /*
    Welcome to Custom CSS!

    CSS (Cascading Style Sheets) is a kind of code that tells the browser how
    to render a web page. You may delete these comments and get started with
    your customizations.

    By default, your stylesheet will be loaded after the theme stylesheets,
    which means that your rules can take precedence and override the theme CSS
    rules. Just write here what you want to change, you don’t need to copy all
    your theme’s stylesheet content.
    */

    #87906

    Marcy
    Participant
    Post count: 286

    Yes. Paste it below all the text that is there. Then save it. When you save it, some or all of the default text may go away. But what you pasted will still be there.

    You can do it!


    #87937

    Gordy
    Participant
    Post count: 86

    Thank you so much. It worked. So, I can use the Jetpack for CSS customization without touching the theme codes.

    Just a quick one if you can help. The time displayed “on the site” is different from what is in “Admin>General setting”.

    I choose custom and am using this : l, F jS, Y g:i a

    Right now it shows : “Friday, January 31st, 2014 2:02 pm” in the “Admin > General”

    but, on the “website”, it shows : “Friday, January 31st, 2014 12:53 pm”

    What can be responsible?

    #87948

    Marcy
    Participant
    Post count: 286

    I’m glad that worked for you! You’re welcome.

    It looks to me like your Timezone is off by 2 hours.
    When you are in your WordPress Admin under Settings > General, just above the Date Format and Time Format is Timezone. Make sure you have the correct one selected. Choose one that gives you the correct time. Then start a new post and see what time it says.

    You may need to log out and close your browser and then open to see a time change if there is caching of your site.

    If that doesn’t work, you’ll need to start a new thread, so some one else can help because I don’t have the old version of that theme. Explain the Date problem and give a link to your site.


Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.